summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorChris Liechti <cliechti@gmx.net>2015-10-23 22:03:04 +0200
committerChris Liechti <cliechti@gmx.net>2015-10-23 22:03:04 +0200
commit72726d743ad71aca54391128370fc41720f4ee09 (patch)
tree8c54702c1b8f3c1e483f4b9f6cc29e3a04c259c2 /setup.py
parentbc5161fd3ea39ae7e1e3bd6274e9c292a9d03bc0 (diff)
downloadpyserial-git-72726d743ad71aca54391128370fc41720f4ee09.tar.gz
updates to setup.py, missing files/subpackages, update classifiers
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py5
1 files changed, 3 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index dcbbdb2..f15e5d8 100644
--- a/setup.py
+++ b/setup.py
@@ -30,9 +30,9 @@ setup(
author = "Chris Liechti",
author_email = "cliechti@gmx.net",
url = "https://github.com/pyserial/pyserial",
- packages = ['serial', 'serial.tools', 'serial.urlhandler'],
+ packages = ['serial', 'serial.tools', 'serial.urlhandler', 'serial.threaded'],
license = "Python",
- long_description = "Python Serial Port Extension for Win32, Linux, BSD, Jython, IronPython",
+ long_description = "Python Serial Port Extension for Win32, OSX, Linux, BSD, Jython, IronPython",
classifiers = [
'Development Status :: 5 - Production/Stable',
'Intended Audience :: Developers',
@@ -41,6 +41,7 @@ setup(
'Natural Language :: English',
'Operating System :: POSIX',
'Operating System :: Microsoft :: Windows',
+ 'Operating System :: MacOS :: MacOS X',
'Programming Language :: Python',
'Programming Language :: Python :: 2',
'Programming Language :: Python :: 2.7',