summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorChris Liechti <cliechti@gmx.net>2015-08-04 02:59:50 +0200
committerChris Liechti <cliechti@gmx.net>2015-08-04 02:59:50 +0200
commit80e2ae2349b2ec6cc8125d6a1378297d0f4f3720 (patch)
tree716acb85a4bf94a7f81230e974593fddb5a01829 /setup.py
parent443e27de14a9a12899c8db600e44428927fc5364 (diff)
downloadpyserial-git-80e2ae2349b2ec6cc8125d6a1378297d0f4f3720.tar.gz
doc update: links, license
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py47
1 files changed, 6 insertions, 41 deletions
diff --git a/setup.py b/setup.py
index 5a0d27f..50493f2 100644
--- a/setup.py
+++ b/setup.py
@@ -13,36 +13,11 @@ import sys
from distutils.core import setup
-if sys.version_info >= (3, 0):
- try:
- from distutils.command.build_py import build_py_2to3 as build_py
- from distutils.command.build_scripts import build_scripts_2to3 as build_scripts
- except ImportError:
- raise ImportError("build_py_2to3 not found in distutils - it is required for Python 3.x")
- else:
- sys.stderr.write('Detected Python 3, using 2to3\n')
-else:
- from distutils.command.build_py import build_py
- from distutils.command.build_scripts import build_scripts
-
-
-if sys.version < '2.3':
- # distutils that old can't cope with the "classifiers" or "download_url"
- # keywords and True/False constants and basestring are missing
- raise ValueError("Sorry Python versions older than 2.3 are no longer"
- "supported - check http://pyserial.sf.net for older "
- "releases or upgrade your Python installation.")
# importing version does not work with Python 3 as files have not yet been
# converted.
-#~ import serial
-#~ version = serial.VERSION
-
-import re, os
-version = re.search(
- "VERSION.*'(.+)'",
- open(os.path.join('serial', '__init__.py')).read()).group(1)
-
+import serial
+version = serial.VERSION
setup(
name = "pyserial",
@@ -50,7 +25,7 @@ setup(
version = version,
author = "Chris Liechti",
author_email = "cliechti@gmx.net",
- url = "http://pyserial.sourceforge.net/",
+ url = "https://github.com/pyserial/pyserial",
packages = ['serial', 'serial.tools', 'serial.urlhandler'],
license = "Python",
long_description = "Python Serial Port Extension for Win32, Linux, BSD, Jython, IronPython",
@@ -58,31 +33,21 @@ setup(
'Development Status :: 5 - Production/Stable',
'Intended Audience :: Developers',
'Intended Audience :: End Users/Desktop',
- 'License :: OSI Approved :: Python Software Foundation License',
+ 'License :: OSI Approved :: BSD License',
'Natural Language :: English',
'Operating System :: POSIX',
'Operating System :: Microsoft :: Windows',
- #~ 'Operating System :: Microsoft :: Windows :: Windows CE', # could work due to new ctypes impl. someone needs to confirm that
'Programming Language :: Python',
'Programming Language :: Python :: 2',
- 'Programming Language :: Python :: 2.3',
- 'Programming Language :: Python :: 2.4',
- 'Programming Language :: Python :: 2.5',
- 'Programming Language :: Python :: 2.6',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.0',
- 'Programming Language :: Python :: 3.1',
- 'Programming Language :: Python :: 3.2',
- 'Programming Language :: Python :: 3.3',
+ 'Programming Language :: Python :: 3.4',
+ 'Programming Language :: Python :: 3.5',
'Topic :: Communications',
'Topic :: Software Development :: Libraries',
'Topic :: Software Development :: Libraries :: Python Modules',
'Topic :: Terminals :: Serial',
],
platforms = 'any',
- cmdclass = {'build_py': build_py, 'build_scripts': build_scripts},
- use_2to3 = sys.version_info >= (3, 0), # for distribute
-
scripts = ['serial/tools/miniterm.py'],
)