summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@flameeyes.com>2019-02-08 12:02:34 +0000
committerDiego Elio Pettenò <flameeyes@flameeyes.com>2019-02-08 12:18:53 +0000
commit8b24cbb6131a97a3e91aabe5299c834a75ae8964 (patch)
tree826d89bb2900c4fcf9356e2523a92b7999c845c8 /setup.py
parenta27715f322bb08b1fccffebab776c94df50057e9 (diff)
downloadpyserial-git-8b24cbb6131a97a3e91aabe5299c834a75ae8964.tar.gz
Add a backend for Silicon Labs CP2110/4 HID-to-UART bridge.
These two chips implement UART access via a HID protocol, which can be implemented purely in user space. The protocol is documented by Silicon Labs AN434: https://www.silabs.com/documents/public/application-notes/AN434-CP2110-4-Interface-Specification.pdf The backend is implemented based on cython-hidapi (https://github.com/trezor/cython-hidapi), making it OS-independent, if a bit awkward.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 3 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 6e8b586..ea53643 100644
--- a/setup.py
+++ b/setup.py
@@ -97,4 +97,7 @@ Latest:
],
platforms='any',
scripts=['serial/tools/miniterm.py'],
+ extras_require = {
+ 'cp2110': ['hidapi'],
+ },
)