summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--pyserial/CHANGES.txt3
-rw-r--r--pyserial/setup.py8
2 files changed, 10 insertions, 1 deletions
diff --git a/pyserial/CHANGES.txt b/pyserial/CHANGES.txt
index c23f406..0d2eeb9 100644
--- a/pyserial/CHANGES.txt
+++ b/pyserial/CHANGES.txt
@@ -244,6 +244,9 @@ New Features:
- ``sendBreak()`` accepts a ``duration`` argument. Default duration increased.
+- update wxSerialConfigDialog.py and wxTerminal.py compatibility with
+ wxPythoon 2.8 (Peleg)
+
- miniterm.py has a new feature to send a file (upload) and configurable
special characters for exit and upload. Refactored internals to class based
structure (upload and class refactoring by Colin D Bennett)
diff --git a/pyserial/setup.py b/pyserial/setup.py
index b0fd0a8..a885d8f 100644
--- a/pyserial/setup.py
+++ b/pyserial/setup.py
@@ -1,5 +1,11 @@
# setup.py
-from distutils.core import setup
+try:
+ from setuptools import setup
+except ImportError:
+ print "standart distutils"
+ from distutils.core import setup
+else:
+ print "setuptools"
import sys
#windows installer: