summaryrefslogtreecommitdiff
path: root/pyparallel/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'pyparallel/setup.py')
-rw-r--r--pyparallel/setup.py38
1 files changed, 3 insertions, 35 deletions
diff --git a/pyparallel/setup.py b/pyparallel/setup.py
index 937923f..749470c 100644
--- a/pyparallel/setup.py
+++ b/pyparallel/setup.py
@@ -1,34 +1,13 @@
#!/usr/bin/env python
-# setup.py
-try:
- from setuptools import setup
-except ImportError:
- print "standart distutils"
- from distutils.core import setup
-else:
- print "setuptools"
-import sys
-
-#windows installer:
-# python setup.py bdist_wininst
-
-# patch distutils if it can't cope with the "classifiers" or
-# "download_url" keywords
-if sys.version < '2.2.3':
- from distutils.dist import DistributionMetadata
- DistributionMetadata.classifiers = None
- DistributionMetadata.download_url = None
+from distutils.core import setup
import os
if os.name == 'nt':
- print "# set dependedcies for windows version"
data_files = {'parallel': ['simpleio.dll']}
else:
- print "# no dependedcies"
- data_files = {}
+ data_files = None
-setup(
- name = "pyparallel",
+setup (name = "pyparallel",
description="Python Parallel Port Extension",
version="0.2",
author="Chris Liechti",
@@ -37,16 +16,5 @@ setup(
packages=['parallel'],
license="Python",
long_description="Python Parallel Port Extension for Win32, Linux, BSD",
- classifiers = [
- 'Development Status :: 4 - Beta',
- 'Intended Audience :: Developers',
- 'License :: OSI Approved :: Python Software Foundation License',
- 'Natural Language :: English',
- 'Operating System :: POSIX',
- 'Operating System :: Microsoft :: Windows',
- 'Programming Language :: Python',
- 'Topic :: Communications',
- 'Topic :: Software Development :: Libraries',
- ],
package_data = data_files
)