summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorcliechti <cliechti@f19166aa-fa4f-0410-85c2-fa1106f25c8a>2003-11-06 22:17:21 +0000
committercliechti <cliechti@f19166aa-fa4f-0410-85c2-fa1106f25c8a>2003-11-06 22:17:21 +0000
commitc1560b4d857ac1913ae97f201637d619f0955232 (patch)
tree43d0cbdaaf4c63f4df15ed3a2c543a276bc7b2c6
parent7f39f70cfdcbfc5b2db9a59411e80d9ff319d2d0 (diff)
downloadpyserial-release2_0@101.tar.gz
2.0 releaserelease2_0@101
changed the setup.py version hack to the recomended code in the distutils docs git-svn-id: http://svn.code.sf.net/p/pyserial/code/trunk@101 f19166aa-fa4f-0410-85c2-fa1106f25c8a
-rw-r--r--pyserial/CHANGES.txt2
-rw-r--r--pyserial/README.txt18
-rw-r--r--pyserial/setup.py12
3 files changed, 27 insertions, 5 deletions
diff --git a/pyserial/CHANGES.txt b/pyserial/CHANGES.txt
index 67f8cc7..7d8d84a 100644
--- a/pyserial/CHANGES.txt
+++ b/pyserial/CHANGES.txt
@@ -132,3 +132,5 @@ Version 2.0b2 4 Oct 2003
- Jython support is currenty broken as Jython does not have a Python 2.2
compatible release out yet
+Version 2.0 6 Nov 2003
+ - Fixes setup.py for older distutils
diff --git a/pyserial/README.txt b/pyserial/README.txt
index 3b0de93..b476eb3 100644
--- a/pyserial/README.txt
+++ b/pyserial/README.txt
@@ -15,11 +15,12 @@ Project Homepage: pyserial.sourceforge.net
Features
--------
- same class based interface on all supported platforms
+- access to the port settings trough Python 2.2 properties
- port numbering starts at zero, no need to know the platform dependant port
name in the user program
- port name can be specified if access through numbering is inappropriate
- support for different bytesizes, stopbits, parity and flow control
- with RTS/CTS and/or xon/xoff
+ with RTS/CTS and/or Xon/Xoff
- working with or without receive timeout, blocking or non-blocking
- file like API with "read" and "write" ("readline" etc. also supported)
- The files in this package are 100% pure Python.
@@ -45,6 +46,12 @@ let Distutils do the rest: "python setup.py install"
The files get installed in the "Lib/site-packages" directory.
+There is also a Windows installer, but for developers it may be interesting
+to get the source archive anyway, because it contains examples and the readme.
+
+Do also have a look at the example files in the examples directory in the
+source distribution or online in CVS repository.
+
Serial to USB adapters
----------------------
Such adapters are reported to work under Mac OSX and Windows. They are
@@ -128,7 +135,9 @@ ser = serial.Serial(
rtscts=0, #enable RTS/CTS flow control
)
-The port is immediately opened on object creation.
+The port is immediately opened on object creation, if a port is given.
+It is not opened if port is None.
+
Options for read timeout:
timeout=None #wait forever
timeout=0 #non-blocking mode (return immediately on read)
@@ -169,9 +178,12 @@ bytesize #bytesize in bits
parity #parity setting
stopbits #stop bit with (1,2)
timeout #timeout setting
-xonxoff #if XonXoff flow control is enabled
+xonxoff #if Xon/Xoff flow control is enabled
rtscts #if hardware flow control is enabled
+Exceptions
+----------
+serial.SerialException
Constants
---------
diff --git a/pyserial/setup.py b/pyserial/setup.py
index 59c7467..6d109f9 100644
--- a/pyserial/setup.py
+++ b/pyserial/setup.py
@@ -1,20 +1,28 @@
# setup.py
from distutils.core import setup
+import sys
#windows installer:
# python setup.py bdist_wininst
+# patch distutils if it can't cope with the "classifiers" or
+# "download_url" keywords
+if sys.version < '2.2.3':
+ from distutils.dist import DistributionMetadata
+ DistributionMetadata.classifiers = None
+ DistributionMetadata.download_url = None
+
setup(
name="pyserial",
description="Python Serial Port Extension",
- version="2.0b2",
+ version="2.0",
author="Chris Liechti",
author_email="cliechti@gmx.net",
url="http://pyserial.sourceforge.net/",
packages=['serial'],
license="Python",
long_description="Python Serial Port Extension for Win32, Linux, BSD, Jython",
- classifiers=[
+ classifiers = [
'Development Status :: 5 - Production/Stable',
'Intended Audience :: Developers',
'Intended Audience :: End Users/Desktop',