summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CHANGES.txt1
-rw-r--r--setup.py4
2 files changed, 2 insertions, 3 deletions
diff --git a/CHANGES.txt b/CHANGES.txt
index 0c07e3f..5878280 100644
--- a/CHANGES.txt
+++ b/CHANGES.txt
@@ -449,6 +449,7 @@ Bugfixes:
- [Bug 3540332] SerialException not returned
- [Bug pyserial:145] Error in socket_connection.py
- [Bug pyserial:135] reading from socket with timeout=None causes TypeError
+- [Bug pyserial:130] setup.py should not append py3k to package name
Bugfixes (posix):
diff --git a/setup.py b/setup.py
index 082bfe1..648ecb2 100644
--- a/setup.py
+++ b/setup.py
@@ -19,11 +19,9 @@ if sys.version_info >= (3, 0):
from distutils.command.build_scripts import build_scripts_2to3 as build_scripts
except ImportError:
raise ImportError("build_py_2to3 not found in distutils - it is required for Python 3.x")
- suffix = "-py3k"
else:
from distutils.command.build_py import build_py
from distutils.command.build_scripts import build_scripts
- suffix = ""
if sys.version < '2.3':
@@ -45,7 +43,7 @@ version = re.search(
setup(
- name = "pyserial" + suffix,
+ name = "pyserial"
description = "Python Serial Port Extension",
version = version,
author = "Chris Liechti",