summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Etingof <etingof@gmail.com>2017-10-05 15:51:39 +0200
committerIlya Etingof <etingof@gmail.com>2017-10-05 15:51:39 +0200
commit82e59461016e8c0608aeec05489385ec4c18479a (patch)
tree7d7712132aaa26316e703d59e622ca88296295f0
parent01605e794e6c4cccfea3c261b7aea0e2130fc23d (diff)
downloadpysnmp-git-82e59461016e8c0608aeec05489385ec4c18479a.tar.gz
pycryptodome replaced with pycryptodomex
-rw-r--r--CHANGES.txt3
-rw-r--r--README.md2
-rw-r--r--devel-requirements.txt1
-rw-r--r--docs/source/download.rst5
-rw-r--r--pysnmp/proto/secmod/eso/priv/des3.py2
-rw-r--r--pysnmp/proto/secmod/rfc3414/priv/des.py2
-rw-r--r--pysnmp/proto/secmod/rfc3826/priv/aes.py2
-rw-r--r--requirements.txt2
-rw-r--r--setup.py4
9 files changed, 13 insertions, 10 deletions
diff --git a/CHANGES.txt b/CHANGES.txt
index c24993f5..04b01820 100644
--- a/CHANGES.txt
+++ b/CHANGES.txt
@@ -3,6 +3,9 @@ Revision 4.4.1, released 2017-10-XX
------------------------------------
- HMAC-SHA-2 Authentication Protocols support added (RFC-7860)
+- The pycryptodome dependency replaced with pycryptodomex as
+ it is recommended by the upstream to avoid unwanted interference
+ with PyCrypto package should it also be installed.
Revision 4.3.10, released 2017-10-XX
------------------------------------
diff --git a/README.md b/README.md
index 0b89f0a7..da8b73ef 100644
--- a/README.md
+++ b/README.md
@@ -56,7 +56,7 @@ $ pip install pysnmp
to download and install PySNMP along with its dependencies:
* [PyASN1](http://pyasn1.sf.net)
-* [PyCryptodome](https://pycryptodome.readthedocs.io) (required only if SNMPv3 encryption is in use)
+* [PyCryptodomex](https://pycryptodome.readthedocs.io) (required only if SNMPv3 encryption is in use)
* [PySMI](http://pysmi.sf.net) (required for MIB services only)
Besides the library, command-line [SNMP utilities](https://github.com/etingof/pysnmp-apps)
diff --git a/devel-requirements.txt b/devel-requirements.txt
new file mode 100644
index 00000000..6966869c
--- /dev/null
+++ b/devel-requirements.txt
@@ -0,0 +1 @@
+sphinx
diff --git a/docs/source/download.rst b/docs/source/download.rst
index 412f6846..a0f43005 100644
--- a/docs/source/download.rst
+++ b/docs/source/download.rst
@@ -48,9 +48,8 @@ operational:
Optional, but recommended:
-* `PyCryptodome <https://pypi.python.org/pypi/pycryptodome/>`_,
- used by SNMPv3 crypto features (Windows users need
- `precompiled version <http://www.voidspace.org.uk/python/modules.shtml>`_)
+* `PyCryptodomex <https://pypi.python.org/pypi/pycryptodomex/>`_,
+ used by SNMPv3 crypto features
* `PySMI <https://pypi.python.org/pypi/pysmi/>`_ for automatic
MIB download and compilation. That helps visualizing more SNMP objects
* `Ply <https://pypi.python.org/pypi/ply/>`_, parser generator
diff --git a/pysnmp/proto/secmod/eso/priv/des3.py b/pysnmp/proto/secmod/eso/priv/des3.py
index ac082c7f..48b07dfa 100644
--- a/pysnmp/proto/secmod/eso/priv/des3.py
+++ b/pysnmp/proto/secmod/eso/priv/des3.py
@@ -24,7 +24,7 @@ except ImportError:
sha1 = sha.new
try:
- from Crypto.Cipher import DES3
+ from Cryptodome.Cipher import DES3
except ImportError:
DES3 = None
diff --git a/pysnmp/proto/secmod/rfc3414/priv/des.py b/pysnmp/proto/secmod/rfc3414/priv/des.py
index dd07d4d0..f1cd2d4a 100644
--- a/pysnmp/proto/secmod/rfc3414/priv/des.py
+++ b/pysnmp/proto/secmod/rfc3414/priv/des.py
@@ -14,7 +14,7 @@ from pyasn1.type import univ
from sys import version_info
try:
- from Crypto.Cipher import DES
+ from Cryptodome.Cipher import DES
except ImportError:
DES = None
try:
diff --git a/pysnmp/proto/secmod/rfc3826/priv/aes.py b/pysnmp/proto/secmod/rfc3826/priv/aes.py
index d390f455..91d9cc23 100644
--- a/pysnmp/proto/secmod/rfc3826/priv/aes.py
+++ b/pysnmp/proto/secmod/rfc3826/priv/aes.py
@@ -13,7 +13,7 @@ from pysnmp.proto.secmod.rfc3414 import localkey
from pysnmp.proto import errind, error
try:
- from Crypto.Cipher import AES
+ from Cryptodome.Cipher import AES
except ImportError:
AES = None
try:
diff --git a/requirements.txt b/requirements.txt
index 4d296bc2..d90ebe40 100644
--- a/requirements.txt
+++ b/requirements.txt
@@ -1,3 +1,3 @@
pysmi
-pycryptodome
+pycryptodomex
pyasn1>=0.2.3
diff --git a/setup.py b/setup.py
index 069ca97d..0fac0fca 100644
--- a/setup.py
+++ b/setup.py
@@ -58,7 +58,7 @@ try:
from setuptools import setup
params = {
- 'install_requires': ['pyasn1>=0.2.3', 'pysmi', 'pycryptodome'],
+ 'install_requires': ['pyasn1>=0.2.3', 'pysmi', 'pycryptodomex'],
'zip_safe': True
}
@@ -72,7 +72,7 @@ except ImportError:
params = {}
if sys.version_info[:2] > (2, 4):
- params['requires'] = ['pyasn1(>=0.2.3)', 'pysmi', 'pycryptodome']
+ params['requires'] = ['pyasn1(>=0.2.3)', 'pysmi', 'pycryptodomex']
doclines = [x.strip() for x in (__doc__ or '').split('\n') if x]