summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Brown <ericwb@users.noreply.github.com>2018-06-27 23:49:59 -0700
committerIlya Etingof <etingof@gmail.com>2018-06-28 08:49:59 +0200
commitf14b61a7daecfbfd217be2319641ba5dfbd87420 (patch)
treed41295d8a3599a6d8e293b04a0336f4f6e57d0ad
parent61f7a10adf83469c76c4182b924d4e002d12641a (diff)
downloadpysnmp-git-f14b61a7daecfbfd217be2319641ba5dfbd87420.tar.gz
Add Python 3.7 support (#162)
Python 3.7 was just released [1]. This is a small change to enable support in pysnmp. [1] https://docs.python.org/3.7/whatsnew/3.7.html Signed-off-by: Eric Brown <browne@vmware.com>
-rw-r--r--.travis.yml1
-rw-r--r--README.md2
-rw-r--r--docs/source/contents.rst2
-rw-r--r--docs/source/development.rst2
-rw-r--r--setup.py1
5 files changed, 5 insertions, 3 deletions
diff --git a/.travis.yml b/.travis.yml
index 56f9a710..4f9d4f24 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -8,6 +8,7 @@ python:
- "3.4"
- "3.5"
- "3.6"
+ - "3.7"
- "nightly"
# - "pypy"
# - "pypy3"
diff --git a/README.md b/README.md
index 31f939c3..9aec21b1 100644
--- a/README.md
+++ b/README.md
@@ -27,7 +27,7 @@ Features
* [PySMI](http://snmplabs.com/pysmi/) integration for dynamic MIB compilation
* Built-in instrumentation exposing protocol engine operations
* Python eggs and py2exe friendly
-* 100% Python, works with Python 2.4 though 3.6
+* 100% Python, works with Python 2.4 though 3.7
* MT-safe (if SnmpEngine is thread-local)
Features, specific to SNMPv3 model include:
diff --git a/docs/source/contents.rst b/docs/source/contents.rst
index d52b0a63..4419c0de 100644
--- a/docs/source/contents.rst
+++ b/docs/source/contents.rst
@@ -17,7 +17,7 @@ multilingual capabilities, remote configuration and other features.
PySNMP implementation closely follows intricate system details and features
bringing most possible power and flexibility to its users.
-Current PySNMP stable version is 4.4. It runs with Python 2.4 through 3.6
+Current PySNMP stable version is 4.4. It runs with Python 2.4 through 3.7
and is recommended for new applications as well as for migration from
older, now obsolete, PySNMP releases. All site documentation and
examples are written for the 4.4 and later versions in mind.
diff --git a/docs/source/development.rst b/docs/source/development.rst
index 920b0ad9..0050f943 100644
--- a/docs/source/development.rst
+++ b/docs/source/development.rst
@@ -93,7 +93,7 @@ sponsoring it. Please get back to us to discuss details.
Contributions to the PySNMP source code is greatly appreciated as well.
We require contributed code to run with Python 2.4 through the latest
-Python version (which is 3.6 at the time of this writing). Contributed
+Python version (which is 3.7 at the time of this writing). Contributed
code will be redistributed under the terms of the same
`license <http://snmplabs.com/pysnmp/>`_ as PySNMP is.
diff --git a/setup.py b/setup.py
index dc9482c6..9f5231b1 100644
--- a/setup.py
+++ b/setup.py
@@ -30,6 +30,7 @@ Programming Language :: Python :: 3.3
Programming Language :: Python :: 3.4
Programming Language :: Python :: 3.5
Programming Language :: Python :: 3.6
+Programming Language :: Python :: 3.7
Topic :: Communications
Topic :: System :: Monitoring
Topic :: System :: Networking :: Monitoring