summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Etingof <etingof@gmail.com>2016-11-05 22:34:30 +0100
committerIlya Etingof <etingof@gmail.com>2016-11-05 22:34:30 +0100
commitbd01807038a1879a8eec1549fc1153adf649ead9 (patch)
tree620206b60668f7b46dfcf172ac1cd3db737d8d8e
parent2ad524609624130bc21c7c2d934be959a5d030d2 (diff)
downloadpysnmp-git-bd01807038a1879a8eec1549fc1153adf649ead9.tar.gz
switched from PyCrypto to PyCryptodome
-rw-r--r--CHANGES.txt1
-rw-r--r--README.md2
-rw-r--r--docs/source/download.rst2
-rw-r--r--requirements.txt2
-rw-r--r--setup.py4
5 files changed, 6 insertions, 5 deletions
diff --git a/CHANGES.txt b/CHANGES.txt
index 305ba88c..fff8eebd 100644
--- a/CHANGES.txt
+++ b/CHANGES.txt
@@ -4,6 +4,7 @@ Revision 4.3.3, work in progress
Github `repo <https://github.com/etingof/pysnmp>`_
+- Switched from now unmaintained PyCrypto to PyCryptodome.
- Switched to new-style classes.
- NotificationType now allows additional var-binds specified as
MIB objects. A side effect of this change is that additional
diff --git a/README.md b/README.md
index af94f09c..12ce74a2 100644
--- a/README.md
+++ b/README.md
@@ -59,7 +59,7 @@ $ pip install pysnmp
to download and install PySNMP along with its dependencies:
* [PyASN1](http://pyasn1.sf.net)
-* [PyCrypto](http://pycrypto.org) (required only if SNMPv3 encryption is in use)
+* [PyCryptodome](https://pycryptodome.readthedocs.io) (required only if SNMPv3 encryption is in use)
* [PySMI](http://pysmi.sf.net) (required for MIB services only)
Besides the library, command-line [SNMP utilities](https://github.com/etingof/pysnmp-apps)
diff --git a/docs/source/download.rst b/docs/source/download.rst
index 2a91e8d6..774b7cce 100644
--- a/docs/source/download.rst
+++ b/docs/source/download.rst
@@ -48,7 +48,7 @@ operational:
Optional, but recommended:
-* `PyCrypto <https://pypi.python.org/pypi/pycrypto/>`_,
+* `PyCryptodome <https://pypi.python.org/pypi/pycryptodome/>`_,
used by SNMPv3 crypto features (Windows users need
`precompiled version <http://www.voidspace.org.uk/python/modules.shtml>`_)
* `PySMI <https://pypi.python.org/pypi/pysmi/>`_ for automatic
diff --git a/requirements.txt b/requirements.txt
index c387225c..ce2d70c6 100644
--- a/requirements.txt
+++ b/requirements.txt
@@ -1,3 +1,3 @@
pyasn1>=0.1.8
pysmi
-pycrypto>=2.4.1
+pycryptodome
diff --git a/setup.py b/setup.py
index 7fd4a89c..746d0703 100644
--- a/setup.py
+++ b/setup.py
@@ -62,7 +62,7 @@ try:
'zip_safe': True
}
if sys.platform.lower()[:3] != 'win':
- params['install_requires'].append('pycrypto>=2.4.1')
+ params['install_requires'].append('pycryptodome')
except ImportError:
for arg in sys.argv:
@@ -75,7 +75,7 @@ except ImportError:
if sys.version_info[:2] > (2, 4):
params['requires'] = ['pyasn1(>=0.1.8)', 'pysmi']
if sys.platform.lower()[:3] != 'win':
- params['requires'].append('pycrypto(>=2.4.1)')
+ params['requires'].append('pycryptodome')
if sys.platform.lower()[:3] == 'win':
try: