summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Etingof <etingof@gmail.com>2018-08-06 23:22:48 +0200
committerIlya Etingof <etingof@gmail.com>2018-08-06 23:22:48 +0200
commitb0bbd37e8208da64fb1ca9d32af2d4fa4803bf4d (patch)
tree5425be5ac2b848c3dbf75c0de943e2b6d9c38416
parentbe8d2caccf94ebbe00e11c739fb28a3b70d39ddc (diff)
downloadpysnmp-git-b0bbd37e8208da64fb1ca9d32af2d4fa4803bf4d.tar.gz
Improve long description in Trove
-rw-r--r--setup.py10
1 files changed, 5 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index 87e56953..0d987d5c 100644
--- a/setup.py
+++ b/setup.py
@@ -1,9 +1,9 @@
#!/usr/bin/env python
"""SNMP library for Python
- SNMP v1/v2c/v3 engine and apps written in pure-Python.
- Supports Manager/Agent/Proxy roles, scriptable MIBs,
- asynchronous operation and multiple transports.
+SNMP v1/v2c/v3 engine and Standard Applications suite written in pure-Python.
+Supports Manager/Agent/Proxy roles, Manager/Agent-side MIBs, asynchronous
+operation and multiple network transports.
"""
import sys
import os
@@ -95,13 +95,13 @@ except ImportError:
re.sub(r'(.*?)([<>=!~]+)(.*)', r'\g<1>\g<2>(\g<3>)', r) for r in requires
]
-doclines = [x.strip() for x in (__doc__ or '').split('\n') if x]
+doclines = [x.strip() for x in (__doc__ or '').split('\n')]
params.update({
'name': 'pysnmp',
'version': open(os.path.join('pysnmp', '__init__.py')).read().split('\'')[1],
'description': doclines[0],
- 'long_description': ' '.join(doclines[1:]),
+ 'long_description': '\n'.join(doclines[1:]),
'maintainer': 'Ilya Etingof <etingof@gmail.com>',
'author': 'Ilya Etingof',
'author_email': 'etingof@gmail.com',