summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Etingof <etingof@gmail.com>2020-03-22 14:45:52 +0100
committerIlya Etingof <etingof@gmail.com>2020-03-22 14:45:52 +0100
commit766357e5acc8169eb47d1d878538cf79ca6c38a8 (patch)
tree290887ece7eb0ed8ec2fae5d9207121dcaee7a1b
parent99305e1c57df497a1406dc0cb13c401e2c296f92 (diff)
downloadpysnmp-git-766357e5acc8169eb47d1d878538cf79ca6c38a8.tar.gz
Improve tox docs builder and fix Travis
-rw-r--r--.travis.yml19
-rw-r--r--MANIFEST.in4
-rw-r--r--devel-requirements.txt2
-rw-r--r--tox.ini43
4 files changed, 38 insertions, 30 deletions
diff --git a/.travis.yml b/.travis.yml
index 3304260a..5b66bea3 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,14 +1,17 @@
language: python
+os: linux
+arch: arm64
+dist: bionic
matrix:
include:
- - python: 2.7
- - python: 3.4
- - python: 3.5
- - python: 3.6
- - python: 3.7
- - python: 3.8
- - python: pypy
- - python: pypy3
+ - python: '2.7'
+ - python: '3.4'
+ - python: '3.5'
+ - python: '3.6'
+ - python: '3.7'
+ - python: '3.8'
+ - python: 'pypy'
+ - python: 'pypy3'
install:
- pip install tox
script:
diff --git a/MANIFEST.in b/MANIFEST.in
index b972478e..1a80ea94 100644
--- a/MANIFEST.in
+++ b/MANIFEST.in
@@ -1,6 +1,6 @@
-include *.rst *.txt *.md *.sh
+include *.rst *.txt *.md
recursive-include examples *.py
-recursive-include tests * * *.sh *.snmprec
+recursive-include tests *.sh *.snmprec
recursive-include docs/source *.rst *.svg *.py
recursive-include docs/mibs *.txt
recursive-include docs *.conf Makefile
diff --git a/devel-requirements.txt b/devel-requirements.txt
index 02629f5e..4e7b9f84 100644
--- a/devel-requirements.txt
+++ b/devel-requirements.txt
@@ -1,5 +1,3 @@
-Sphinx <= 1.6; python_version < '2.7'
-Sphinx > 1.6; python_version >= '2.7'
trollius; python_version < '3.0'
# NOTE: Twisted < 19.2.1 has a security problem in URL handling.
# However, newer Twisted does not work on older Pythons. That's why
diff --git a/tox.ini b/tox.ini
index 96cc33d9..b20c1f79 100644
--- a/tox.ini
+++ b/tox.ini
@@ -15,46 +15,50 @@ deps = pip >= 19.3.1
install_command =
pip install {opts} {packages}
-[testenv:functest]
+[testenv:testbench]
deps =
{[testenv]deps}
-r{toxinidir}/requirements.txt
-r{toxinidir}/devel-requirements.txt
+
+[testenv:simulator]
+deps =
+ {[testenv:testbench]deps}
snmpsim<1.0.0
commands =
{toxinidir}/tests/functional/runtests.sh {envpython}
[testenv:py26-functest]
-deps = {[testenv:functest]deps}
-commands = {[testenv:functest]commands}
+deps = {[testenv:simulator]deps}
+commands = {[testenv:simulator]commands}
[testenv:py27-functest]
-deps = {[testenv:functest]deps}
-commands = {[testenv:functest]commands}
+deps = {[testenv:simulator]deps}
+commands = {[testenv:simulator]commands}
[testenv:py35-functest]
-deps = {[testenv:functest]deps}
-commands = {[testenv:functest]commands}
+deps = {[testenv:simulator]deps}
+commands = {[testenv:simulator]commands}
[testenv:py36-functest]
-deps = {[testenv:functest]deps}
-commands = {[testenv:functest]commands}
+deps = {[testenv:simulator]deps}
+commands = {[testenv:simulator]commands}
[testenv:py37-functest]
-deps = {[testenv:functest]deps}
-commands = {[testenv:functest]commands}
+deps = {[testenv:simulator]deps}
+commands = {[testenv:simulator]commands}
[testenv:py38-functest]
-deps = {[testenv:functest]deps}
-commands = {[testenv:functest]commands}
+deps = {[testenv:simulator]deps}
+commands = {[testenv:simulator]commands}
[testenv:pypy-functest]
-deps = {[testenv:functest]deps}
-commands = {[testenv:functest]commands}
+deps = {[testenv:simulator]deps}
+commands = {[testenv:simulator]commands}
[testenv:pypy3-functest]
-deps = {[testenv:functest]deps}
-commands = {[testenv:functest]commands}
+deps = {[testenv:simulator]deps}
+commands = {[testenv:simulator]commands}
[testenv:bandit]
skip_install = true
@@ -65,6 +69,9 @@ commands =
[testenv:docs]
whitelist_externals = make
+deps =
+ {[testenv:testbench]deps}
+ sphinx
commands = make -C docs html
[testenv:build]
@@ -73,4 +80,4 @@ deps =
wheel
setuptools
commands =
- python setup.py -q sdist bdist_wheel
+ python setup.py -q sdist bdist_wheel bdist_egg