summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.travis.yml19
-rw-r--r--MANIFEST.in2
-rw-r--r--README.md3
-rwxr-xr-xruntests.sh17
4 files changed, 40 insertions, 1 deletions
diff --git a/.travis.yml b/.travis.yml
new file mode 100644
index 00000000..e4486081
--- /dev/null
+++ b/.travis.yml
@@ -0,0 +1,19 @@
+
+language: python
+python:
+ - "2.6"
+ - "2.7"
+ - "3.2"
+ - "3.3"
+ - "3.4"
+ - "3.5"
+ - "nightly"
+ - "pypy"
+ - "pypy3"
+install:
+ - pip install pyasn1
+ - pip install pycrypto
+ - pip install pysmi
+ - python setup.py install
+script:
+ - sh runtests.sh
diff --git a/MANIFEST.in b/MANIFEST.in
index c35aaffe..c72432c2 100644
--- a/MANIFEST.in
+++ b/MANIFEST.in
@@ -1,4 +1,4 @@
-include *.txt *.md
+include *.txt *.md *.sh
recursive-include examples *.py
recursive-include docs/source *.rst *.svg *.py
recursive-include docs/mibs *.txt
diff --git a/README.md b/README.md
index 6186deec..74f31064 100644
--- a/README.md
+++ b/README.md
@@ -1,6 +1,9 @@
SNMP library for Python
-----------------------
+[![Downloads](https://img.shields.io/pypi/dm/pysnmp.svg)](https://pypi.python.org/pypi/pysnmp)
+[![Build status](https://travis-ci.org/etingof/pysnmp.svg?branch=master)](https://secure.travis-ci.org/etingof/pysnmp)
+[![GitHub license](https://img.shields.io/badge/license-BSD-blue.svg)](https://raw.githubusercontent.com/etingof/pysnmp/master/LICENSE.txt)
This is a pure-Python, open source and free implementation of v1/v2c/v3
SNMP engine distributed under 2-clause [BSD license](http://pysnmp.sourceforge.net/license.html).
diff --git a/runtests.sh b/runtests.sh
new file mode 100755
index 00000000..3ccc1656
--- /dev/null
+++ b/runtests.sh
@@ -0,0 +1,17 @@
+#!/usr/bin/env sh
+
+set -e
+
+for x in examples/hlapi/asyncore/sync/manager/cmdgen/*.py \
+ examples/hlapi/asyncore/sync/agent/ntforg/*.py \
+ examples/hlapi/asyncore/manager/cmdgen/*.py \
+ examples/hlapi/asyncore/agent/ntforg/*.py \
+ examples/v3arch/asyncore/manager/cmdgen/*.py \
+ examples/v3arch/asyncore/agent/ntforg/*.py \
+ examples/v1arch/asyncore/manager/cmdgen/*.py \
+ examples/v1arch/asyncore/agent/ntforg/*.py \
+ examples/smi/manager/*py \
+ examples/smi/agent/*.py
+do
+ python $x
+done \ No newline at end of file