summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Jerdonek <chris.jerdonek@gmail.com>2012-03-30 18:59:32 -0700
committerChris Jerdonek <chris.jerdonek@gmail.com>2012-03-30 18:59:32 -0700
commit5ba98b3d39d1d52ab8bd7fb53cd2c10a7b9405fe (patch)
tree7e3320668d7f1ff4ed916268dc644a99961a9171
parente4c083f6fdd8c132bdcaeb4ff9466cc81acd9318 (diff)
parenta06fd4233d55ea317ea03b81c98b149e3d5b1364 (diff)
downloadpystache-5ba98b3d39d1d52ab8bd7fb53cd2c10a7b9405fe.tar.gz
Merge branch 'master' into 'development': v0.4.1 changes
Conflicts: HISTORY.rst README.rst examples/nested_context.py pystache/template.py setup.py
-rw-r--r--HISTORY.rst4
-rw-r--r--README.rst18
-rw-r--r--examples/nested_context.py4
-rw-r--r--setup.py5
4 files changed, 26 insertions, 5 deletions
diff --git a/HISTORY.rst b/HISTORY.rst
index d867634..8ca8169 100644
--- a/HISTORY.rst
+++ b/HISTORY.rst
@@ -39,6 +39,10 @@ Misc:
* Added some docstrings. [kennethreitz]
+0.4.1 (2012-03-25)
+------------------
+* Added support for Python 2.4. [wangtz, jvantuyl]
+
0.4.0 (2011-01-12)
------------------
* Add support for nested contexts (within template and view)
diff --git a/README.rst b/README.rst
index b83e0be..c16bcb4 100644
--- a/README.rst
+++ b/README.rst
@@ -19,10 +19,17 @@ tests in `version 1.0.3`_ of the spec.
Logo: `David Phillips`_
+
Requirements
============
-Pystache is currently tested under Python 2.6.
+Pystache currently works using the following versions of Python:
+
+* Python 2.4
+* Python 2.5
+* Python 2.6
+* Python 2.7
+
Install It
==========
@@ -75,6 +82,11 @@ nose_ works great! ::
cd pystache
nosetests
+Depending on your Python version and nose installation, you may need
+to type, for example ::
+
+ nosetests-2.4
+
To include tests from the Mustache spec in your test runs: ::
git submodule init
@@ -92,8 +104,9 @@ To run a subset of the tests, you can use this pattern, for example: ::
nosetests --tests tests/test_context.py:GetValueTests.test_dictionary__key_present
+
Mailing List
-==================
+============
As of November 2011, there's a mailing list, pystache@librelist.com.
@@ -102,6 +115,7 @@ Archive: http://librelist.com/browser/pystache/
Note: There's a bit of a delay in seeing the latest emails appear
in the archive.
+
Author
======
diff --git a/examples/nested_context.py b/examples/nested_context.py
index e3f803f..6fd0aea 100644
--- a/examples/nested_context.py
+++ b/examples/nested_context.py
@@ -16,4 +16,6 @@ class NestedContext(pystache.View):
return [{'outer': 'car'}]
def nested_context_in_view(self):
- return 'it works!' if self.context.get('outer') == self.context.get('inner') else '' \ No newline at end of file
+ if self.context.get('outer') == self.context.get('inner'):
+ return 'it works!'
+ return ''
diff --git a/setup.py b/setup.py
index da8f8d7..e96230b 100644
--- a/setup.py
+++ b/setup.py
@@ -70,7 +70,7 @@ if sys.argv[-1] == 'publish':
long_description = make_long_description()
setup(name='pystache',
- version='0.4.0',
+ version='0.4.1',
description='Mustache for Python',
long_description=long_description,
author='Chris Wanstrath',
@@ -85,8 +85,9 @@ setup(name='pystache',
'Development Status :: 4 - Beta',
'License :: OSI Approved :: MIT License',
'Programming Language :: Python',
+ 'Programming Language :: Python :: 2.4',
'Programming Language :: Python :: 2.5',
'Programming Language :: Python :: 2.6',
+ 'Programming Language :: Python :: 2.7',
)
)
-