summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Jerdonek <chris.jerdonek@gmail.com>2012-11-04 00:53:18 -0700
committerChris Jerdonek <chris.jerdonek@gmail.com>2012-11-04 00:53:18 -0700
commit6430cac4477f441203e1100a5dc9e79428c36066 (patch)
tree852ca5619d9c6dfcd73991ca6007794487e8d01a
parent1c4f9b6fdd72c0a327646966bc3628241ebac37a (diff)
downloadpystache-6430cac4477f441203e1100a5dc9e79428c36066.tar.gz
Make setup.py print to stderr instead of stdout in at least one case.
This helps when piping the output of `python setup.py --long-description` to other programs like rst2html.py.
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 7eda3d0..4cb2e78 100644
--- a/setup.py
+++ b/setup.py
@@ -365,7 +365,7 @@ def main(sys_argv):
# TODO: use the logging module instead of printing.
# TODO: include the following in a verbose mode.
- print("pystache: using: version %s of %s" % (repr(dist.__version__), repr(dist)))
+ sys.stderr.write("pystache: using: version %s of %s\n" % (repr(dist.__version__), repr(dist)))
command = sys_argv[-1]