summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorChris Jerdonek <chris.jerdonek@gmail.com>2012-03-08 04:11:57 -0800
committerChris Jerdonek <chris.jerdonek@gmail.com>2012-03-08 04:11:57 -0800
commit0b2415f24153dbf62d03f26d5e2cd9d958626fb3 (patch)
tree021a882a00b9eda9baeb028d30f89a1aa0b12142 /setup.py
parent304381d889ce8970349883617da60a86959cced5 (diff)
downloadpystache-0b2415f24153dbf62d03f26d5e2cd9d958626fb3.tar.gz
Added documentation on how to push to PyPI.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py26
1 files changed, 24 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 40c69bb..453faa6 100644
--- a/setup.py
+++ b/setup.py
@@ -2,9 +2,31 @@
# coding: utf-8
"""
-Run the following to publish to PyPI:
+To push a new version of pystache to PyPI--
-> python setup.py publish
+ http://pypi.python.org/pypi/pystache
+
+you first need to be added as a "Package Index Owner" of pystache.
+
+Then run the following (after preparing the release, bumping the version
+number, etc):
+
+ > python setup.py publish
+
+If you get an error like the following--
+
+ Upload failed (401): You must be identified to edit package information
+
+then add a file called .pyirc to your home directory with the following
+contents:
+
+ [server-login]
+ username: <PyPI username>
+ password: <PyPI password>
+
+as described here, for example:
+
+ http://docs.python.org/release/2.5.2/dist/pypirc.html
"""