summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
authorChris Jerdonek <chris.jerdonek@gmail.com>2012-04-10 18:49:48 -0700
committerChris Jerdonek <chris.jerdonek@gmail.com>2012-04-10 18:49:48 -0700
commit6d2f1b4871e56013d6bdd1672445d731e4009475 (patch)
tree72f0a2805b3960b6262ec47d5cee6813de2ad984 /tox.ini
parentf124d46ebdf8a9b93b93070d85cae57ef6c971a7 (diff)
downloadpystache-6d2f1b4871e56013d6bdd1672445d731e4009475.tar.gz
Got tox working with Python 2.4 through 3.2 (2.4, 2.5, 2.6, 2.7, 3.2).
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini36
1 files changed, 36 insertions, 0 deletions
diff --git a/tox.ini b/tox.ini
new file mode 100644
index 0000000..0a3e871
--- /dev/null
+++ b/tox.ini
@@ -0,0 +1,36 @@
+# A tox configuration file to test across multiple Python versions.
+#
+# http://pypi.python.org/pypi/tox
+#
+[tox]
+envlist = py32,py31,py27,py26,py25,py24
+
+[testenv]
+deps =
+ # Distribute works with Python 2.3.5 and above:
+ # http://packages.python.org/distribute/setuptools.html#building-and-distributing-packages-with-distribute
+ distribute
+commands =
+ python setup.py --quiet test
+
+# We use nosetests for older versions of Python to find doctests because
+# the load_tests protocol (which we use for finding doctests when using
+# Distribute's `test`) was not introduced until Python 2.7.
+
+[testenv:py26]
+deps =
+ nose
+commands =
+ python setup.py --quiet nosetests
+
+[testenv:py25]
+deps =
+ nose
+commands =
+ python setup.py --quiet nosetests
+
+[testenv:py24]
+deps =
+ nose
+commands =
+ python setup.py --quiet nosetests