summaryrefslogtreecommitdiff
path: root/.travis.yml
diff options
context:
space:
mode:
authorJason R. Coombs <jaraco@jaraco.com>2016-10-24 10:03:06 -0400
committerJason R. Coombs <jaraco@jaraco.com>2016-10-24 10:03:06 -0400
commitcc4b90df96d0c362bed5802f23dfdc5552c7bf0a (patch)
tree4f545e018bbb06b9f74877dfb58ef257f9a7f39a /.travis.yml
parent66a11081bfa8d9f873ab21ee011404262adedb2b (diff)
parent95fd34c61f8d9df2e9c559b3978c85e7d03cd8d8 (diff)
downloadpytest-runner-cc4b90df96d0c362bed5802f23dfdc5552c7bf0a.tar.gz
Merge with skeleton
Diffstat (limited to '.travis.yml')
-rw-r--r--.travis.yml7
1 files changed, 5 insertions, 2 deletions
diff --git a/.travis.yml b/.travis.yml
index 22c86d4..a46869e 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -3,12 +3,15 @@ language: python
python:
- 2.7
- 3.5
+install:
+- pip install tox "setuptools>=28.2"
script:
-- pip install -U pytest
-- python setup.py test
+- tox
branches:
except:
- skeleton
+before_deploy:
+- pip install https://dl.dropboxusercontent.com/u/54081/cheeseshop/setuptools_scm-1.15.0rc1.tar.gz
deploy:
provider: pypi
server: https://upload.pypi.org/legacy/