summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason R. Coombs <jaraco@jaraco.com>2016-08-15 21:05:28 -0400
committerJason R. Coombs <jaraco@jaraco.com>2016-08-15 21:05:28 -0400
commit0271f71a1189d3b19702483379b92389e4e37f5d (patch)
treef0815b35b4cd9d88948af63a625e91c9280d2f30
parentd2d77777ed4a52b059bdd390278c7d05fdb5a2b1 (diff)
parentd024388cac7d3804c763e6f5656e75a6bde7d33c (diff)
downloadpytest-runner-0271f71a1189d3b19702483379b92389e4e37f5d.tar.gz
Merge with skeleton
-rw-r--r--.travis.yml3
-rw-r--r--README.rst11
-rw-r--r--setup.cfg6
3 files changed, 16 insertions, 4 deletions
diff --git a/.travis.yml b/.travis.yml
index fb285f9..22c86d4 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -11,11 +11,12 @@ branches:
- skeleton
deploy:
provider: pypi
+ server: https://upload.pypi.org/legacy/
on:
tags: true
all_branches: true
python: 3.5
user: jaraco
- distributions: release
+ distributions: dist
password:
secure: lZfYQx0ZrCf2FJ+348etKWfzTySB3BZYGd0ce5RFHN2BppcdkONyJfTs4rgdrFEn/WtOaKV3SkJYR09xvlr+4kbLibg7fXhueqZt0ZkhRBnoDE4SxCjICyFCmisG6O3zkrVosizch70/0MqseNanhgXOPhd5llCfQHIqLsa145BG4hM5kxAHPO3Rz2/HCObOTPe4HKj93RAK7lPIMZVN6omcWoG6ZB0QqK+i3LTUtmJ3gE6q/iHk3VF9cJs8xtn3hdo++Lhrboa2NIqf6fl8oxR1C24Wh8vBQ69uTNjmVnDFYMulTs5475jjgDBXPPgVz3CAqYAy/PI+NPw59ebK8MzlaMRK/h/xSrdhxW6K3WbBL71Dn2UGuejXHFC3IuCI832xwkuEupOcGLWz4r2uBnhbgXF63vZ2gYPqrCGHxvDpbtllTVyEeebP8BnFzZttxSn9rbhTP1O9Dn/9tRko8WskyXIR+/2JOA9KP5uT47yeHoFBBUS0GB1XdkGhBrJfQx2LhfHuI6bpzosMiMfJrVNZEg8k0I9XA0uwxDgZrdqKGMKBR6233MXiJg8NyUPRInCRGth4rufcq6kn+wsT9RvuSt9XOhGiYLwChjvHexUXrLGBgupu0Y80Oqcp3YkDG3WHUX++Z2zJSQovrb4BMdKS6Y4usQ8Df5SklIpMCf0=
diff --git a/README.rst b/README.rst
index 8e86ffb..00a1500 100644
--- a/README.rst
+++ b/README.rst
@@ -1,5 +1,12 @@
-pytest-runner
-=============
+.. image:: https://img.shields.io/pypi/v/pytest-runner.svg
+ :target: https://pypi.org/project/pytest-runner
+
+.. image:: https://img.shields.io/pypi/pyversions/pytest-runner.svg
+
+.. image:: https://img.shields.io/pypi/dm/pytest-runner.svg
+
+.. image:: https://img.shields.io/travis/jaraco/pytest-runner/master.svg
+ :target: http://travis-ci.org/jaraco/pytest-runner
Setup scripts can use pytest-runner to add setup.py test support for pytest
runner.
diff --git a/setup.cfg b/setup.cfg
index 8004dcb..dcd8d12 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,6 +1,10 @@
[aliases]
-release = clean --all sdist bdist_wheel build_sphinx upload upload_docs
+release = dists build_sphinx upload upload_docs
+dists = clean --all sdist bdist_wheel
test = pytest
[wheel]
universal = 1
+
+[upload]
+repository = https://upload.pypi.org/legacy/