summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason R. Coombs <jaraco@jaraco.com>2016-10-24 10:03:06 -0400
committerJason R. Coombs <jaraco@jaraco.com>2016-10-24 10:03:06 -0400
commitcc4b90df96d0c362bed5802f23dfdc5552c7bf0a (patch)
tree4f545e018bbb06b9f74877dfb58ef257f9a7f39a
parent66a11081bfa8d9f873ab21ee011404262adedb2b (diff)
parent95fd34c61f8d9df2e9c559b3978c85e7d03cd8d8 (diff)
downloadpytest-runner-cc4b90df96d0c362bed5802f23dfdc5552c7bf0a.tar.gz
Merge with skeleton
-rw-r--r--.travis.yml7
-rw-r--r--README.rst4
-rw-r--r--docs/conf.py4
-rw-r--r--pytest.ini2
-rw-r--r--setup.cfg1
-rw-r--r--setup.py9
-rw-r--r--tests/requirements.txt1
-rw-r--r--tox.ini6
8 files changed, 21 insertions, 13 deletions
diff --git a/.travis.yml b/.travis.yml
index 22c86d4..a46869e 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -3,12 +3,15 @@ language: python
python:
- 2.7
- 3.5
+install:
+- pip install tox "setuptools>=28.2"
script:
-- pip install -U pytest
-- python setup.py test
+- tox
branches:
except:
- skeleton
+before_deploy:
+- pip install https://dl.dropboxusercontent.com/u/54081/cheeseshop/setuptools_scm-1.15.0rc1.tar.gz
deploy:
provider: pypi
server: https://upload.pypi.org/legacy/
diff --git a/README.rst b/README.rst
index 7a4ef67..908e726 100644
--- a/README.rst
+++ b/README.rst
@@ -11,6 +11,10 @@
Setup scripts can use pytest-runner to add setup.py test support for pytest
runner.
+License is indicated in the project metadata (typically one or more
+of the Trove classifiers). For more details, see `this explanation
+<https://github.com/jaraco/skeleton/issues/1>`_.
+
Usage
-----
diff --git a/docs/conf.py b/docs/conf.py
index ebc0453..fe7c018 100644
--- a/docs/conf.py
+++ b/docs/conf.py
@@ -1,7 +1,7 @@
#!/usr/bin/env python3
# -*- coding: utf-8 -*-
-import setuptools_scm
+import pkg_resources
extensions = [
'sphinx.ext.autodoc',
@@ -13,7 +13,7 @@ project = 'pytest-runner'
copyright = '2015,2016 Jason R. Coombs'
# The short X.Y version.
-version = setuptools_scm.get_version(root='..', relative_to=__file__)
+version = pkg_resources.require(project)[0].version
# The full version, including alpha/beta/rc tags.
release = version
diff --git a/pytest.ini b/pytest.ini
index 9752c36..56a8774 100644
--- a/pytest.ini
+++ b/pytest.ini
@@ -1,4 +1,4 @@
[pytest]
-norecursedirs=*.egg .eggs dist build
+norecursedirs=dist build .tox
addopts=--doctest-modules
doctest_optionflags=ALLOW_UNICODE ELLIPSIS
diff --git a/setup.cfg b/setup.cfg
index f5ee607..4659acc 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,7 +1,6 @@
[aliases]
release = dists upload
dists = clean --all sdist bdist_wheel
-test = pytest
[wheel]
universal = 1
diff --git a/setup.py b/setup.py
index f1d1d7b..b0547f6 100644
--- a/setup.py
+++ b/setup.py
@@ -10,8 +10,6 @@ import setuptools
with io.open('README.rst', encoding='utf-8') as readme:
long_description = readme.read()
-needs_pytest = set(['pytest', 'test']).intersection(sys.argv)
-pytest_runner = ['pytest_runner'] if needs_pytest else []
needs_wheel = set(['release', 'bdist_wheel', 'dists']).intersection(sys.argv)
wheel = ['wheel'] if needs_wheel else []
@@ -33,11 +31,8 @@ setup_params = dict(
extras_require={
},
setup_requires=[
- 'setuptools_scm>=1.9',
- ] + pytest_runner + wheel,
- tests_require=[
- 'pytest>=2.8',
- ],
+ 'setuptools_scm>=1.9,!=1.13.1,!=1.14.0',
+ ] + wheel,
classifiers=[
"Development Status :: 5 - Production/Stable",
"Intended Audience :: Developers",
diff --git a/tests/requirements.txt b/tests/requirements.txt
new file mode 100644
index 0000000..70bc02f
--- /dev/null
+++ b/tests/requirements.txt
@@ -0,0 +1 @@
+pytest >= 2.8
diff --git a/tox.ini b/tox.ini
new file mode 100644
index 0000000..d740130
--- /dev/null
+++ b/tox.ini
@@ -0,0 +1,6 @@
+[testenv]
+deps =
+ -rtests/requirements.txt
+
+commands = py.test {posargs}
+usedevelop = True