summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason R. Coombs <jaraco@jaraco.com>2016-04-02 22:44:23 -0400
committerJason R. Coombs <jaraco@jaraco.com>2016-04-02 22:44:23 -0400
commitbbf28379f4d8cb8c308dfa36605ef63c9031a207 (patch)
treeb2826607481ca0e5fb317d841b91af2bef82ef71
parent24c1111b4f4702a241ab57bddef8e7989842b9a2 (diff)
parent01e953bac9ac132fba90550492ee9f7eedfce7e0 (diff)
downloadpytest-runner-bbf28379f4d8cb8c308dfa36605ef63c9031a207.tar.gz
Merge with skeleton. Fixes #15.2.7.1
-rw-r--r--.travis.yml17
-rw-r--r--docs/conf.py20
-rw-r--r--docs/history.rst2
-rw-r--r--setup.cfg2
-rw-r--r--setup.py13
5 files changed, 43 insertions, 11 deletions
diff --git a/.travis.yml b/.travis.yml
index 6e5e969..7ff32e9 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,8 +1,17 @@
sudo: false
language: python
python:
- - 2.7
- - 3.5
+- 2.7
+- 3.5
script:
- - pip install -U pytest
- - python setup.py test
+- pip install -U pytest
+- python setup.py test
+deploy:
+ provider: pypi
+ on:
+ tags: true
+ all_branches: true
+ user: jaraco
+ # supply password with `travis encrypt --add deploy.password`
+ distributions: release
+ python: 3.5
diff --git a/docs/conf.py b/docs/conf.py
index 81000ce..135c236 100644
--- a/docs/conf.py
+++ b/docs/conf.py
@@ -5,6 +5,7 @@ import setuptools_scm
extensions = [
'sphinx.ext.autodoc',
+ 'rst.linker',
]
# General information about the project.
@@ -17,3 +18,22 @@ version = setuptools_scm.get_version(root='..', relative_to=__file__)
release = version
master_doc = 'index'
+
+link_files = {
+ 'CHANGES.rst': dict(
+ using=dict(
+ GH='https://github.com',
+ project=project,
+ ),
+ replace=[
+ dict(
+ pattern=r"(Issue )?#(?P<issue>\d+)",
+ url='{GH}/jaraco/{project}/issues/{issue}',
+ ),
+ dict(
+ pattern=r"^(?m)((?P<scm_version>v?\d+(\.\d+){1,2}))\n[-=]+\n",
+ with_scm="{text}\n{rev[timestamp]:%d %b %Y}\n",
+ ),
+ ],
+ ),
+}
diff --git a/docs/history.rst b/docs/history.rst
index 907000b..8e21750 100644
--- a/docs/history.rst
+++ b/docs/history.rst
@@ -5,4 +5,4 @@
History
*******
-.. include:: ../CHANGES.rst
+.. include:: ../CHANGES (links).rst
diff --git a/setup.cfg b/setup.cfg
index 445263a..8004dcb 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,5 +1,5 @@
[aliases]
-release = sdist bdist_wheel build_sphinx upload upload_docs
+release = clean --all sdist bdist_wheel build_sphinx upload upload_docs
test = pytest
[wheel]
diff --git a/setup.py b/setup.py
index 36ce32d..a81681d 100644
--- a/setup.py
+++ b/setup.py
@@ -13,19 +13,22 @@ with io.open('README.rst', encoding='utf-8') as readme:
needs_pytest = set(['pytest', 'test']).intersection(sys.argv)
pytest_runner = ['pytest_runner'] if needs_pytest else []
needs_sphinx = set(['release', 'build_sphinx', 'upload_docs']).intersection(sys.argv)
-sphinx = ['sphinx'] if needs_sphinx else []
+sphinx = ['sphinx', 'rst.linker'] if needs_sphinx else []
needs_wheel = set(['release', 'bdist_wheel']).intersection(sys.argv)
wheel = ['wheel'] if needs_wheel else []
+name = 'pytest-runner'
+description = 'Invoke py.test as distutils command with dependency resolution'
+
setup_params = dict(
- name='pytest-runner',
+ name=name,
use_scm_version=True,
author="Jason R. Coombs",
author_email="jaraco@jaraco.com",
- description="Invoke py.test as distutils command with dependency "
- "resolution.",
+ description=description or name,
long_description=long_description,
- url="https://github.com/pytest-dev/pytest-runner",
+ url="https://github.com/pytest-dev/" + name,
+ namespace_packages=name.split('.')[:-1],
py_modules=['ptr'],
install_requires=[
],