summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason R. Coombs <jaraco@jaraco.com>2015-12-19 22:29:56 -0500
committerJason R. Coombs <jaraco@jaraco.com>2015-12-19 22:29:56 -0500
commit5ad18328e8f38abcc5a0fc4a549e7a3c40697d4e (patch)
tree7f1fef09ea1478c2722af01db5e5537a16b5b882
downloadpytest-runner-5ad18328e8f38abcc5a0fc4a549e7a3c40697d4e.tar.gz
Generate project skeleton
-rw-r--r--.hgignore2
-rw-r--r--.travis.yml8
-rw-r--r--CHANGES.rst0
-rw-r--r--README.rst2
-rw-r--r--docs/conf.py19
-rw-r--r--docs/history.rst8
-rw-r--r--docs/index.rst22
-rw-r--r--pytest.ini4
-rw-r--r--setup.cfg6
-rw-r--r--setup.py51
-rw-r--r--skeleton/__init__.py0
11 files changed, 122 insertions, 0 deletions
diff --git a/.hgignore b/.hgignore
new file mode 100644
index 0000000..9d0b71a
--- /dev/null
+++ b/.hgignore
@@ -0,0 +1,2 @@
+build
+dist
diff --git a/.travis.yml b/.travis.yml
new file mode 100644
index 0000000..6e5e969
--- /dev/null
+++ b/.travis.yml
@@ -0,0 +1,8 @@
+sudo: false
+language: python
+python:
+ - 2.7
+ - 3.5
+script:
+ - pip install -U pytest
+ - python setup.py test
diff --git a/CHANGES.rst b/CHANGES.rst
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/CHANGES.rst
diff --git a/README.rst b/README.rst
new file mode 100644
index 0000000..217a075
--- /dev/null
+++ b/README.rst
@@ -0,0 +1,2 @@
+skeleton
+========
diff --git a/docs/conf.py b/docs/conf.py
new file mode 100644
index 0000000..c834848
--- /dev/null
+++ b/docs/conf.py
@@ -0,0 +1,19 @@
+#!/usr/bin/env python3
+# -*- coding: utf-8 -*-
+
+import setuptools_scm
+
+extensions = [
+ 'sphinx.ext.autodoc',
+]
+
+# General information about the project.
+project = 'skeleton'
+copyright = '2015 Jason R. Coombs'
+
+# The short X.Y version.
+version = setuptools_scm.get_version(root='..', relative_to=__file__)
+# The full version, including alpha/beta/rc tags.
+release = version
+
+master_doc = 'index'
diff --git a/docs/history.rst b/docs/history.rst
new file mode 100644
index 0000000..907000b
--- /dev/null
+++ b/docs/history.rst
@@ -0,0 +1,8 @@
+:tocdepth: 2
+
+.. _changes:
+
+History
+*******
+
+.. include:: ../CHANGES.rst
diff --git a/docs/index.rst b/docs/index.rst
new file mode 100644
index 0000000..d14131b
--- /dev/null
+++ b/docs/index.rst
@@ -0,0 +1,22 @@
+Welcome to skeleton documentation!
+========================================
+
+.. toctree::
+ :maxdepth: 1
+
+ history
+
+
+.. automodule:: skeleton
+ :members:
+ :undoc-members:
+ :show-inheritance:
+
+
+Indices and tables
+==================
+
+* :ref:`genindex`
+* :ref:`modindex`
+* :ref:`search`
+
diff --git a/pytest.ini b/pytest.ini
new file mode 100644
index 0000000..9752c36
--- /dev/null
+++ b/pytest.ini
@@ -0,0 +1,4 @@
+[pytest]
+norecursedirs=*.egg .eggs dist build
+addopts=--doctest-modules
+doctest_optionflags=ALLOW_UNICODE ELLIPSIS
diff --git a/setup.cfg b/setup.cfg
new file mode 100644
index 0000000..445263a
--- /dev/null
+++ b/setup.cfg
@@ -0,0 +1,6 @@
+[aliases]
+release = sdist bdist_wheel build_sphinx upload upload_docs
+test = pytest
+
+[wheel]
+universal = 1
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..e6edf34
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,51 @@
+#!/usr/bin/env python
+# Generated by jaraco.develop 2.27.1
+# https://pypi.python.org/pypi/jaraco.develop
+
+import io
+import sys
+
+import setuptools
+
+with io.open('README.rst', encoding='utf-8') as readme:
+ long_description = readme.read()
+
+needs_pytest = {'pytest', 'test'}.intersection(sys.argv)
+pytest_runner = ['pytest_runner'] if needs_pytest else []
+needs_sphinx = {'release', 'build_sphinx', 'upload_docs'}.intersection(sys.argv)
+sphinx = ['sphinx'] if needs_sphinx else []
+needs_wheel = {'release', 'bdist_wheel'}.intersection(sys.argv)
+wheel = ['wheel'] if needs_wheel else []
+
+setup_params = dict(
+ name='skeleton',
+ use_scm_version=True,
+ author="Jason R. Coombs",
+ author_email="jaraco@jaraco.com",
+ description="skeleton",
+ long_description=long_description,
+ url="https://github.com/jaraco/skeleton",
+ packages=setuptools.find_packages(),
+ include_package_data=True,
+ install_requires=[
+ ],
+ extras_require={
+ },
+ setup_requires=[
+ 'setuptools_scm>=1.9',
+ ] + pytest_runner + sphinx + wheel,
+ tests_require=[
+ 'pytest>=2.8',
+ ],
+ classifiers=[
+ "Development Status :: 5 - Production/Stable",
+ "Intended Audience :: Developers",
+ "License :: OSI Approved :: MIT License",
+ "Programming Language :: Python :: 2.7",
+ "Programming Language :: Python :: 3",
+ ],
+ entry_points={
+ },
+)
+if __name__ == '__main__':
+ setuptools.setup(**setup_params)
diff --git a/skeleton/__init__.py b/skeleton/__init__.py
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/skeleton/__init__.py