summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason R. Coombs <jaraco@jaraco.com>2018-02-10 14:33:48 -0500
committerJason R. Coombs <jaraco@jaraco.com>2018-02-10 14:33:48 -0500
commit016a84e3bc1ec56b6986b3f33144892ac618a5d5 (patch)
tree7ff2d8da69b945940e33603c5c985f67267ec462
parentfe39989ce5358c5e4311a61c359445668a17dd9b (diff)
parent3902aabd7f5c4cb0f4aba8d2785da98e87cb7d6a (diff)
downloadpytest-runner-016a84e3bc1ec56b6986b3f33144892ac618a5d5.tar.gz
Merge https://github.com/jaraco/skeleton
-rw-r--r--.travis.yml10
-rw-r--r--README.rst5
-rw-r--r--appveyor.yml2
-rw-r--r--docs/conf.py6
-rw-r--r--pytest.ini2
-rw-r--r--setup.cfg3
-rw-r--r--setup.py2
-rw-r--r--tox.ini11
8 files changed, 30 insertions, 11 deletions
diff --git a/.travis.yml b/.travis.yml
index 7ca9276..e570814 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -2,12 +2,14 @@ dist: trusty
sudo: false
language: python
+python:
+- 2.7
+- &latest_py3 3.6
+- nightly
+
jobs:
fast_finish: true
include:
- - python: 2.7
- - python: &latest_py3 3.6
- - python: nightly
- stage: deploy
if: tag IS present
python: *latest_py3
@@ -28,6 +30,6 @@ jobs:
cache: pip
install:
-- pip install tox
+- pip install tox tox-venv
script: tox
diff --git a/README.rst b/README.rst
index f571e0e..0395be7 100644
--- a/README.rst
+++ b/README.rst
@@ -4,7 +4,10 @@
.. image:: https://img.shields.io/pypi/pyversions/pytest-runner.svg
.. image:: https://img.shields.io/travis/pytest-dev/pytest-runner/master.svg
- :target: http://travis-ci.org/pytest-dev/pytest-runner
+ :target: https://travis-ci.org/pytest-dev/pytest-runner
+
+.. image:: https://readthedocs.org/projects/pytest-runner/badge/?version=latest
+ :target: https://pytest-runner.readthedocs.io/en/latest/?badge=latest
Setup scripts can use pytest-runner to add setup.py test support for pytest
runner.
diff --git a/appveyor.yml b/appveyor.yml
index 0a8ce5c..3d55a92 100644
--- a/appveyor.yml
+++ b/appveyor.yml
@@ -15,7 +15,7 @@ install:
build: off
test_script:
- - "python -m pip install tox"
+ - "python -m pip install tox tox-venv"
- "tox"
version: '{build}'
diff --git a/docs/conf.py b/docs/conf.py
index 5d50361..c82b462 100644
--- a/docs/conf.py
+++ b/docs/conf.py
@@ -2,9 +2,9 @@
# -*- coding: utf-8 -*-
extensions = [
- 'sphinx.ext.autodoc',
- 'jaraco.packaging.sphinx',
- 'rst.linker',
+ 'sphinx.ext.autodoc',
+ 'jaraco.packaging.sphinx',
+ 'rst.linker',
]
master_doc = 'index'
diff --git a/pytest.ini b/pytest.ini
index 56a8774..1b2f624 100644
--- a/pytest.ini
+++ b/pytest.ini
@@ -1,4 +1,4 @@
[pytest]
-norecursedirs=dist build .tox
+norecursedirs=dist build .tox .eggs
addopts=--doctest-modules
doctest_optionflags=ALLOW_UNICODE ELLIPSIS
diff --git a/setup.cfg b/setup.cfg
index b0c90cb..378a8e4 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -4,3 +4,6 @@ dists = clean --all sdist bdist_wheel
[bdist_wheel]
universal = 1
+
+[metadata]
+license_file = LICENSE
diff --git a/setup.py b/setup.py
index b41096f..b96db52 100644
--- a/setup.py
+++ b/setup.py
@@ -36,7 +36,7 @@ params = dict(
extras_require={
'testing': [
'pytest>=2.8',
- 'pytest-sugar',
+ 'pytest-sugar>=0.9.1',
'collective.checkdocs',
'pytest-virtualenv',
],
diff --git a/tox.ini b/tox.ini
index 16bf78a..df1b0ef 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,9 +1,20 @@
[tox]
+envlist = python
minversion = 2.4
[testenv]
+deps =
+ setuptools>=31.0.1
commands =
py.test {posargs}
python setup.py checkdocs
usedevelop = True
extras = testing
+
+[testenv:build-docs]
+extras =
+ docs
+ testing
+changedir = docs
+commands =
+ python -m sphinx . {toxinidir}/build/html