summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason R. Coombs <jaraco@jaraco.com>2018-03-03 13:33:07 -0500
committerJason R. Coombs <jaraco@jaraco.com>2018-03-03 13:36:28 -0500
commit40da2c65007ccc250c7d897d497ef2b3fb58f3d4 (patch)
tree10ba3813e720619254e54a0c826be2659810269a
parent41b814aa6cff3c46788a1d410095061a82af2076 (diff)
downloadpytest-runner-40da2c65007ccc250c7d897d497ef2b3fb58f3d4.tar.gz
Run flake8 with tests. Add flake8 config to ignore common exclusions. Add comments to testing and docs extras to aid with merges.
-rw-r--r--.flake82
-rw-r--r--pytest.ini2
-rw-r--r--setup.py7
3 files changed, 10 insertions, 1 deletions
diff --git a/.flake8 b/.flake8
new file mode 100644
index 0000000..e9955e7
--- /dev/null
+++ b/.flake8
@@ -0,0 +1,2 @@
+[flake8]
+ignore = W191,W503
diff --git a/pytest.ini b/pytest.ini
index 1b2f624..0ba22c3 100644
--- a/pytest.ini
+++ b/pytest.ini
@@ -1,4 +1,4 @@
[pytest]
norecursedirs=dist build .tox .eggs
-addopts=--doctest-modules
+addopts=--doctest-modules --flake8
doctest_optionflags=ALLOW_UNICODE ELLIPSIS
diff --git a/setup.py b/setup.py
index 9e73e23..c5ad4b1 100644
--- a/setup.py
+++ b/setup.py
@@ -36,14 +36,21 @@ params = dict(
],
extras_require={
'testing': [
+ # upstream
'pytest>=2.8',
'pytest-sugar>=0.9.1',
'collective.checkdocs',
+ 'pytest-flake8',
+
+ # local
],
'docs': [
+ # upstream
'sphinx',
'jaraco.packaging>=3.2',
'rst.linker>=1.9',
+
+ # local
],
},
setup_requires=[