summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason R. Coombs <jaraco@jaraco.com>2017-10-27 09:55:12 -0400
committerJason R. Coombs <jaraco@jaraco.com>2017-10-27 09:55:12 -0400
commit59735f374dd0085e54eed110c4979a1bff2ed53e (patch)
treebda7d2112d8f1a94cfbd13fb3d33108bb79ceb94
parent932c91db97fe8a93ce54f4f4e04e2fd1e28b2275 (diff)
parent2c970db6066919e1120dfadc259cf7f433290445 (diff)
downloadpytest-runner-59735f374dd0085e54eed110c4979a1bff2ed53e.tar.gz
Merge branch 'master' into feature/drop-py26
-rw-r--r--.travis.yml52
-rw-r--r--CHANGES.rst10
-rw-r--r--LICENSE22
-rw-r--r--README.rst10
-rw-r--r--ptr.py5
-rw-r--r--setup.py1
-rw-r--r--tests/test_ptr.py14
-rw-r--r--tox.ini4
8 files changed, 65 insertions, 53 deletions
diff --git a/.travis.yml b/.travis.yml
index 03d4e22..7ca9276 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,25 +1,33 @@
+dist: trusty
sudo: false
language: python
-python:
-- 2.7
-- 3.6
-- nightly
+
+jobs:
+ fast_finish: true
+ include:
+ - python: 2.7
+ - python: &latest_py3 3.6
+ - python: nightly
+ - stage: deploy
+ if: tag IS present
+ python: *latest_py3
+ install: skip
+ script: skip
+ deploy:
+ provider: pypi
+ on:
+ tags: true
+ all_branches: true
+ user: jaraco
+ password:
+ secure: lZfYQx0ZrCf2FJ+348etKWfzTySB3BZYGd0ce5RFHN2BppcdkONyJfTs4rgdrFEn/WtOaKV3SkJYR09xvlr+4kbLibg7fXhueqZt0ZkhRBnoDE4SxCjICyFCmisG6O3zkrVosizch70/0MqseNanhgXOPhd5llCfQHIqLsa145BG4hM5kxAHPO3Rz2/HCObOTPe4HKj93RAK7lPIMZVN6omcWoG6ZB0QqK+i3LTUtmJ3gE6q/iHk3VF9cJs8xtn3hdo++Lhrboa2NIqf6fl8oxR1C24Wh8vBQ69uTNjmVnDFYMulTs5475jjgDBXPPgVz3CAqYAy/PI+NPw59ebK8MzlaMRK/h/xSrdhxW6K3WbBL71Dn2UGuejXHFC3IuCI832xwkuEupOcGLWz4r2uBnhbgXF63vZ2gYPqrCGHxvDpbtllTVyEeebP8BnFzZttxSn9rbhTP1O9Dn/9tRko8WskyXIR+/2JOA9KP5uT47yeHoFBBUS0GB1XdkGhBrJfQx2LhfHuI6bpzosMiMfJrVNZEg8k0I9XA0uwxDgZrdqKGMKBR6233MXiJg8NyUPRInCRGth4rufcq6kn+wsT9RvuSt9XOhGiYLwChjvHexUXrLGBgupu0Y80Oqcp3YkDG3WHUX++Z2zJSQovrb4BMdKS6Y4usQ8Df5SklIpMCf0=
+ distributions: dists
+ skip_cleanup: true
+ skip_upload_docs: true
+
+cache: pip
+
install:
-- pip install tox "setuptools>=28.2"
-script:
-- tox
-branches:
- except:
- - skeleton
-deploy:
- provider: pypi
- server: https://upload.pypi.org/legacy/
- on:
- tags: true
- all_branches: true
- python: 3.6
- user: jaraco
- distributions: dists
- skip_upload_docs: true
- password:
- secure: lZfYQx0ZrCf2FJ+348etKWfzTySB3BZYGd0ce5RFHN2BppcdkONyJfTs4rgdrFEn/WtOaKV3SkJYR09xvlr+4kbLibg7fXhueqZt0ZkhRBnoDE4SxCjICyFCmisG6O3zkrVosizch70/0MqseNanhgXOPhd5llCfQHIqLsa145BG4hM5kxAHPO3Rz2/HCObOTPe4HKj93RAK7lPIMZVN6omcWoG6ZB0QqK+i3LTUtmJ3gE6q/iHk3VF9cJs8xtn3hdo++Lhrboa2NIqf6fl8oxR1C24Wh8vBQ69uTNjmVnDFYMulTs5475jjgDBXPPgVz3CAqYAy/PI+NPw59ebK8MzlaMRK/h/xSrdhxW6K3WbBL71Dn2UGuejXHFC3IuCI832xwkuEupOcGLWz4r2uBnhbgXF63vZ2gYPqrCGHxvDpbtllTVyEeebP8BnFzZttxSn9rbhTP1O9Dn/9tRko8WskyXIR+/2JOA9KP5uT47yeHoFBBUS0GB1XdkGhBrJfQx2LhfHuI6bpzosMiMfJrVNZEg8k0I9XA0uwxDgZrdqKGMKBR6233MXiJg8NyUPRInCRGth4rufcq6kn+wsT9RvuSt9XOhGiYLwChjvHexUXrLGBgupu0Y80Oqcp3YkDG3WHUX++Z2zJSQovrb4BMdKS6Y4usQ8Df5SklIpMCf0=
+- pip install tox
+
+script: tox
diff --git a/CHANGES.rst b/CHANGES.rst
index 63142ff..0e59e0a 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -3,6 +3,16 @@
* Dropped support for Python 2.6 and 3.1.
+2.12.2
+~~~~~~
+
+* #33: Packaging refresh.
+
+2.12.1
+~~~~~~
+
+* #32: Fix support for ``dependency_links``.
+
2.12
~~~~
diff --git a/LICENSE b/LICENSE
index 49c95bf..5e795a6 100644
--- a/LICENSE
+++ b/LICENSE
@@ -1,21 +1,7 @@
-The MIT License (MIT)
+Copyright Jason R. Coombs
-Copyright (c) 2011-2016 Jason R. Coombs
+Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:
-Permission is hereby granted, free of charge, to any person obtaining a copy of
-this software and associated documentation files (the "Software"), to deal in
-the Software without restriction, including without limitation the rights to
-use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies
-of the Software, and to permit persons to whom the Software is furnished to do
-so, subject to the following conditions:
+The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.
-The above copyright notice and this permission notice shall be included in all
-copies or substantial portions of the Software.
-
-THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
-IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
-FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
-AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
-LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
-OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
-SOFTWARE.
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
diff --git a/README.rst b/README.rst
index d9c9288..f571e0e 100644
--- a/README.rst
+++ b/README.rst
@@ -3,22 +3,12 @@
.. image:: https://img.shields.io/pypi/pyversions/pytest-runner.svg
-.. image:: https://img.shields.io/pypi/dm/pytest-runner.svg
-
.. image:: https://img.shields.io/travis/pytest-dev/pytest-runner/master.svg
:target: http://travis-ci.org/pytest-dev/pytest-runner
Setup scripts can use pytest-runner to add setup.py test support for pytest
runner.
-
-License
-=======
-
-License is indicated in the project metadata (typically one or more
-of the Trove classifiers). For more details, see `this explanation
-<https://github.com/jaraco/skeleton/issues/1>`_.
-
Usage
-----
diff --git a/ptr.py b/ptr.py
index ecba60c..56a5c00 100644
--- a/ptr.py
+++ b/ptr.py
@@ -173,7 +173,10 @@ class PyTest(orig.test):
dist = CustomizedDist()
for attr in 'allow_hosts index_url'.split():
setattr(dist, attr, getattr(self, attr))
- for attr in 'install_requires tests_require extras_require'.split():
+ for attr in (
+ 'dependency_links install_requires '
+ 'tests_require extras_require '
+ ).split():
setattr(dist, attr, getattr(self.distribution, attr))
installed_dists = self.install_dists(dist)
if self.dry_run:
diff --git a/setup.py b/setup.py
index 8d0f491..b41096f 100644
--- a/setup.py
+++ b/setup.py
@@ -37,6 +37,7 @@ params = dict(
'testing': [
'pytest>=2.8',
'pytest-sugar',
+ 'collective.checkdocs',
'pytest-virtualenv',
],
'docs': [
diff --git a/tests/test_ptr.py b/tests/test_ptr.py
index aac5e75..fcbf0c5 100644
--- a/tests/test_ptr.py
+++ b/tests/test_ptr.py
@@ -2,6 +2,7 @@ from __future__ import unicode_literals
import io
import os
+import shutil
import sys
import tarfile
import textwrap
@@ -87,6 +88,13 @@ def test_egg_fetcher(venv, setuptools_req, test_args):
</body></html>
'''
).format(dist_sdist=dist_sdist))
+ # Move barbazquux1 out of the index.
+ shutil.move(index_dir / 'barbazquux1', venv.workspace)
+ barbazquux1_link = (
+ 'file://' + str(venv.workspace.abspath())
+ + '/barbazquux1/barbazquux1-0.1.tar.gz'
+ + '#egg=barbazquux1-0.1'
+ )
# Prepare fake project.
project_dir = (venv.workspace / 'project-0.1').mkdir()
with open(project_dir / 'setup.py', 'w') as fp:
@@ -96,6 +104,9 @@ def test_egg_fetcher(venv, setuptools_req, test_args):
setup(
name='project',
version='0.1',
+ dependency_links = [
+ {barbazquux1_link!r},
+ ],
setup_requires=[
'pytest-runner',
],
@@ -112,7 +123,8 @@ def test_egg_fetcher(venv, setuptools_req, test_args):
'extra': 'barbazquux5',
}}
)
- ''').format(sys_platform=sys.platform))
+ ''').format(sys_platform=sys.platform,
+ barbazquux1_link=barbazquux1_link))
with open(project_dir / 'setup.cfg', 'w') as fp:
fp.write(DALS(
'''
diff --git a/tox.ini b/tox.ini
index 1ae06ef..16bf78a 100644
--- a/tox.ini
+++ b/tox.ini
@@ -2,6 +2,8 @@
minversion = 2.4
[testenv]
-commands = py.test {posargs}
+commands =
+ py.test {posargs}
+ python setup.py checkdocs
usedevelop = True
extras = testing