summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason R. Coombs <jaraco@jaraco.com>2017-09-13 04:24:11 -0400
committerJason R. Coombs <jaraco@jaraco.com>2017-09-13 04:24:11 -0400
commit88d315ae9adab430bd36722da8c6ab74c2e79cf0 (patch)
treeaa2eca265eba8fc85c4b822240208b448b7d5ed3
parent250cb960021233160e78a6f2c2780cfc1c964b9c (diff)
downloadpytest-runner-88d315ae9adab430bd36722da8c6ab74c2e79cf0.tar.gz
Check the docs during tests
-rw-r--r--setup.py1
-rw-r--r--tox.ini4
2 files changed, 4 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 72d901c..75f2371 100644
--- a/setup.py
+++ b/setup.py
@@ -38,6 +38,7 @@ params = dict(
'testing': [
'pytest>=2.8',
'pytest-sugar',
+ 'collective.checkdocs',
],
'docs': [
'sphinx',
diff --git a/tox.ini b/tox.ini
index 1ae06ef..16bf78a 100644
--- a/tox.ini
+++ b/tox.ini
@@ -2,6 +2,8 @@
minversion = 2.4
[testenv]
-commands = py.test {posargs}
+commands =
+ py.test {posargs}
+ python setup.py checkdocs
usedevelop = True
extras = testing