summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason R. Coombs <jaraco@jaraco.com>2018-01-17 09:55:12 -0500
committerJason R. Coombs <jaraco@jaraco.com>2018-01-17 09:55:12 -0500
commit99d850f0ed9852993626d4869e9f096e1643be6d (patch)
treea37ea494573d60c491ff65680d010eb456f3bdcd
parent63659653697e9037ed5cb5a770dc00b07c77e5a9 (diff)
downloadpytest-runner-99d850f0ed9852993626d4869e9f096e1643be6d.tar.gz
To support namespace packages, Setuptools must be 31.0.1. This change is necessary with the adoption of tox-venv, which uses Python's venv, which does not install the latest setuptools by default.
-rw-r--r--tox.ini2
1 files changed, 2 insertions, 0 deletions
diff --git a/tox.ini b/tox.ini
index 7cccd42..df1b0ef 100644
--- a/tox.ini
+++ b/tox.ini
@@ -3,6 +3,8 @@ envlist = python
minversion = 2.4
[testenv]
+deps =
+ setuptools>=31.0.1
commands =
py.test {posargs}
python setup.py checkdocs