summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason R. Coombs <jaraco@jaraco.com>2017-10-27 09:34:17 -0400
committerJason R. Coombs <jaraco@jaraco.com>2017-10-27 09:34:17 -0400
commita4af89a7ecf387bd57f9372832aedd4952bc8cfd (patch)
tree77948903ef2bd0ff233a76c9a61c48951dfdf86d
parente5ccb8ed654beba6e22d90197097f446899f08bf (diff)
parent34958ccc94b8c473ebf8adcdc35b82b6023d8702 (diff)
downloadpytest-runner-a4af89a7ecf387bd57f9372832aedd4952bc8cfd.tar.gz
Merge https://github.com/jaraco/skeleton
-rw-r--r--.travis.yml52
-rw-r--r--LICENSE22
-rw-r--r--README.rst10
-rw-r--r--setup.py1
-rw-r--r--tox.ini4
5 files changed, 38 insertions, 51 deletions
diff --git a/.travis.yml b/.travis.yml
index 03d4e22..7ca9276 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,25 +1,33 @@
+dist: trusty
sudo: false
language: python
-python:
-- 2.7
-- 3.6
-- nightly
+
+jobs:
+ fast_finish: true
+ include:
+ - python: 2.7
+ - python: &latest_py3 3.6
+ - python: nightly
+ - stage: deploy
+ if: tag IS present
+ python: *latest_py3
+ install: skip
+ script: skip
+ deploy:
+ provider: pypi
+ on:
+ tags: true
+ all_branches: true
+ user: jaraco
+ password:
+ secure: lZfYQx0ZrCf2FJ+348etKWfzTySB3BZYGd0ce5RFHN2BppcdkONyJfTs4rgdrFEn/WtOaKV3SkJYR09xvlr+4kbLibg7fXhueqZt0ZkhRBnoDE4SxCjICyFCmisG6O3zkrVosizch70/0MqseNanhgXOPhd5llCfQHIqLsa145BG4hM5kxAHPO3Rz2/HCObOTPe4HKj93RAK7lPIMZVN6omcWoG6ZB0QqK+i3LTUtmJ3gE6q/iHk3VF9cJs8xtn3hdo++Lhrboa2NIqf6fl8oxR1C24Wh8vBQ69uTNjmVnDFYMulTs5475jjgDBXPPgVz3CAqYAy/PI+NPw59ebK8MzlaMRK/h/xSrdhxW6K3WbBL71Dn2UGuejXHFC3IuCI832xwkuEupOcGLWz4r2uBnhbgXF63vZ2gYPqrCGHxvDpbtllTVyEeebP8BnFzZttxSn9rbhTP1O9Dn/9tRko8WskyXIR+/2JOA9KP5uT47yeHoFBBUS0GB1XdkGhBrJfQx2LhfHuI6bpzosMiMfJrVNZEg8k0I9XA0uwxDgZrdqKGMKBR6233MXiJg8NyUPRInCRGth4rufcq6kn+wsT9RvuSt9XOhGiYLwChjvHexUXrLGBgupu0Y80Oqcp3YkDG3WHUX++Z2zJSQovrb4BMdKS6Y4usQ8Df5SklIpMCf0=
+ distributions: dists
+ skip_cleanup: true
+ skip_upload_docs: true
+
+cache: pip
+
install:
-- pip install tox "setuptools>=28.2"
-script:
-- tox
-branches:
- except:
- - skeleton
-deploy:
- provider: pypi
- server: https://upload.pypi.org/legacy/
- on:
- tags: true
- all_branches: true
- python: 3.6
- user: jaraco
- distributions: dists
- skip_upload_docs: true
- password:
- secure: lZfYQx0ZrCf2FJ+348etKWfzTySB3BZYGd0ce5RFHN2BppcdkONyJfTs4rgdrFEn/WtOaKV3SkJYR09xvlr+4kbLibg7fXhueqZt0ZkhRBnoDE4SxCjICyFCmisG6O3zkrVosizch70/0MqseNanhgXOPhd5llCfQHIqLsa145BG4hM5kxAHPO3Rz2/HCObOTPe4HKj93RAK7lPIMZVN6omcWoG6ZB0QqK+i3LTUtmJ3gE6q/iHk3VF9cJs8xtn3hdo++Lhrboa2NIqf6fl8oxR1C24Wh8vBQ69uTNjmVnDFYMulTs5475jjgDBXPPgVz3CAqYAy/PI+NPw59ebK8MzlaMRK/h/xSrdhxW6K3WbBL71Dn2UGuejXHFC3IuCI832xwkuEupOcGLWz4r2uBnhbgXF63vZ2gYPqrCGHxvDpbtllTVyEeebP8BnFzZttxSn9rbhTP1O9Dn/9tRko8WskyXIR+/2JOA9KP5uT47yeHoFBBUS0GB1XdkGhBrJfQx2LhfHuI6bpzosMiMfJrVNZEg8k0I9XA0uwxDgZrdqKGMKBR6233MXiJg8NyUPRInCRGth4rufcq6kn+wsT9RvuSt9XOhGiYLwChjvHexUXrLGBgupu0Y80Oqcp3YkDG3WHUX++Z2zJSQovrb4BMdKS6Y4usQ8Df5SklIpMCf0=
+- pip install tox
+
+script: tox
diff --git a/LICENSE b/LICENSE
index 49c95bf..5e795a6 100644
--- a/LICENSE
+++ b/LICENSE
@@ -1,21 +1,7 @@
-The MIT License (MIT)
+Copyright Jason R. Coombs
-Copyright (c) 2011-2016 Jason R. Coombs
+Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:
-Permission is hereby granted, free of charge, to any person obtaining a copy of
-this software and associated documentation files (the "Software"), to deal in
-the Software without restriction, including without limitation the rights to
-use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies
-of the Software, and to permit persons to whom the Software is furnished to do
-so, subject to the following conditions:
+The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.
-The above copyright notice and this permission notice shall be included in all
-copies or substantial portions of the Software.
-
-THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
-IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
-FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
-AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
-LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
-OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
-SOFTWARE.
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
diff --git a/README.rst b/README.rst
index d9c9288..f571e0e 100644
--- a/README.rst
+++ b/README.rst
@@ -3,22 +3,12 @@
.. image:: https://img.shields.io/pypi/pyversions/pytest-runner.svg
-.. image:: https://img.shields.io/pypi/dm/pytest-runner.svg
-
.. image:: https://img.shields.io/travis/pytest-dev/pytest-runner/master.svg
:target: http://travis-ci.org/pytest-dev/pytest-runner
Setup scripts can use pytest-runner to add setup.py test support for pytest
runner.
-
-License
-=======
-
-License is indicated in the project metadata (typically one or more
-of the Trove classifiers). For more details, see `this explanation
-<https://github.com/jaraco/skeleton/issues/1>`_.
-
Usage
-----
diff --git a/setup.py b/setup.py
index 1e95a0e..8ef7332 100644
--- a/setup.py
+++ b/setup.py
@@ -37,6 +37,7 @@ params = dict(
'testing': [
'pytest>=2.8',
'pytest-sugar',
+ 'collective.checkdocs',
'pytest-virtualenv',
],
'testing:python_version=="2.6"': [
diff --git a/tox.ini b/tox.ini
index 1ae06ef..16bf78a 100644
--- a/tox.ini
+++ b/tox.ini
@@ -2,6 +2,8 @@
minversion = 2.4
[testenv]
-commands = py.test {posargs}
+commands =
+ py.test {posargs}
+ python setup.py checkdocs
usedevelop = True
extras = testing