summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason R. Coombs <jaraco@jaraco.com>2018-02-10 14:59:40 -0500
committerJason R. Coombs <jaraco@jaraco.com>2018-02-10 15:00:42 -0500
commitb11624dea5b6337e442f0103c9b2f1bdd44b2995 (patch)
tree799d9baeab82bfbbd0fb0d3899aa848f89d6f255
parent95f4e9fbd57add2505f0325bd53246389f46006c (diff)
downloadpytest-runner-b11624dea5b6337e442f0103c9b2f1bdd44b2995.tar.gz
Use === for separator in changelog and readme, matching convention in other projects.
-rw-r--r--CHANGES.rst44
-rw-r--r--README.rst10
2 files changed, 27 insertions, 27 deletions
diff --git a/CHANGES.rst b/CHANGES.rst
index b0ad590..28f1b8a 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -1,5 +1,5 @@
3.0.1
-~~~~~
+=====
* #38: Fixed AttributeError when running with ``--dry-run``.
``PyTest.run()`` no longer returns the result code. Based on
@@ -8,22 +8,22 @@
nothing has ever relied on that value.
3.0
-~~~
+===
* Dropped support for Python 2.6 and 3.1.
2.12.2
-~~~~~~
+======
* #33: Packaging refresh.
2.12.1
-~~~~~~
+======
* #32: Fix support for ``dependency_links``.
2.12
-~~~~
+====
* #30: Rework support for ``--allow-hosts`` and
``--index-url``, removing dependence on
@@ -32,23 +32,23 @@
along with unit tests!
2.11.1
-~~~~~~
+======
* #28: Fix logic in marker evaluation.
2.11
-~~~~
+====
* #27: Improved wording in the README around configuration
for the distutils command and pytest proper.
2.10.1
-~~~~~~
+======
* #21: Avoid mutating dictionary keys during iteration.
2.10
-~~~~
+====
* #20: Leverage technique in `setuptools 794
<https://github.com/pypa/setuptools/issues/794>`_
@@ -57,13 +57,13 @@
comparable to the test runner.
2.9
-~~~
+===
* Added Trove Classifier indicating this package is part
of the pytest framework.
2.8
-~~~
+===
* #16: Added a license file, required for membership to
pytest-dev.
@@ -71,28 +71,28 @@
tagged release that passes tests on Python 3.5.
2.7
-~~~
+===
* Moved hosting to Github.
2.6
-~~~
+===
* Add support for un-named, environment-specific extras.
2.5.1
-~~~~~
+=====
* Restore Python 2.6 compatibility.
2.5
-~~~
+===
* Moved hosting to `pytest-dev
<https://bitbucket.org/pytest-dev/pytest-runner>`_.
2.4
-~~~
+===
* Added `documentation <https://pythonhosted.org/pytest-runner>`_.
* Use setuptools_scm for version management and file discovery.
@@ -100,23 +100,23 @@
in the package metadata.
2.3
-~~~
+===
* Use hgdistver for version management and file discovery.
2.2
-~~~
+===
* Honor ``.eggs`` directory for transient downloads as introduced in Setuptools
7.0.
2.1
-~~~
+===
* The preferred invocation is now the 'pytest' command.
2.0
-~~~
+===
* Removed support for the alternate usage. The recommended usage (as a
distutils command) is now the only supported usage.
@@ -125,13 +125,13 @@
via the --addopts parameter.
1.1
-~~~
+===
* Added support for --addopts to pass any arguments through to py.test.
* Deprecated support for --junitxml. Use --addopts instead. --junitxml will be
removed in 2.0.
1.0
-~~~
+===
Initial implementation.
diff --git a/README.rst b/README.rst
index 0395be7..2ad0825 100644
--- a/README.rst
+++ b/README.rst
@@ -13,7 +13,7 @@ Setup scripts can use pytest-runner to add setup.py test support for pytest
runner.
Usage
------
+=====
- Add 'pytest-runner' to your 'setup_requires'. Pin to '>=2.0,<3dev' (or
similar) to avoid pulling in incompatible versions.
@@ -32,7 +32,7 @@ Usage
to cause ``python setup.py test`` to invoke pytest.
Example
--------
+=======
The most simple usage looks like this in setup.py::
@@ -54,7 +54,7 @@ Follow `this search on github
for examples of real-world usage.
Standalone Example
-------------------
+==================
This technique is deprecated - if you have standalone scripts
you wish to invoke with dependencies, `use rwt
@@ -87,10 +87,10 @@ As a result, the communication barrier for describing and
replicating failures is made almost trivially low.
Considerations
---------------
+==============
Conditional Requirement
-~~~~~~~~~~~~~~~~~~~~~~~
+-----------------------
Because it uses Setuptools setup_requires, pytest-runner will install itself
on every invocation of setup.py. In some cases, this causes delays for