summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason R. Coombs <jaraco@jaraco.com>2018-03-17 15:02:02 -0400
committerJason R. Coombs <jaraco@jaraco.com>2018-03-17 15:02:02 -0400
commite553c1576b7db2f2cd867461856eda71177cd731 (patch)
tree1f1b53684133e5445364e6d650855de7ed1e55f8
parent139db200fdaba09dfacd0c59ba6e1bff664c4ebf (diff)
parentcd31f81d564c1cd93c7cbf0b1b19c034e310ad52 (diff)
downloadpytest-runner-e553c1576b7db2f2cd867461856eda71177cd731.tar.gz
Merge https://github.com/jaraco/skeleton
-rw-r--r--.flake82
-rw-r--r--README.rst6
-rw-r--r--appveyor.yml3
-rw-r--r--pytest.ini2
-rw-r--r--setup.py7
-rw-r--r--tox.ini2
6 files changed, 21 insertions, 1 deletions
diff --git a/.flake8 b/.flake8
new file mode 100644
index 0000000..e9955e7
--- /dev/null
+++ b/.flake8
@@ -0,0 +1,2 @@
+[flake8]
+ignore = W191,W503
diff --git a/README.rst b/README.rst
index f5cfba7..80247ce 100644
--- a/README.rst
+++ b/README.rst
@@ -6,6 +6,12 @@
.. image:: https://img.shields.io/travis/pytest-dev/pytest-runner/master.svg
:target: https://travis-ci.org/pytest-dev/pytest-runner
+.. .. image:: https://img.shields.io/appveyor/ci/pytest-dev/pytest-runner/master.svg
+.. :target: https://ci.appveyor.com/project/pytest-dev/pytest-runner/branch/master
+
+.. .. image:: https://readthedocs.org/projects/pytest-runner/badge/?version=latest
+.. :target: https://pytest-runner.readthedocs.io/en/latest/?badge=latest
+
Setup scripts can use pytest-runner to add setup.py test support for pytest
runner.
diff --git a/appveyor.yml b/appveyor.yml
index 3d55a92..2b7808f 100644
--- a/appveyor.yml
+++ b/appveyor.yml
@@ -14,6 +14,9 @@ install:
build: off
+cache:
+ - '%LOCALAPPDATA%\pip\Cache'
+
test_script:
- "python -m pip install tox tox-venv"
- "tox"
diff --git a/pytest.ini b/pytest.ini
index 1b2f624..0ba22c3 100644
--- a/pytest.ini
+++ b/pytest.ini
@@ -1,4 +1,4 @@
[pytest]
norecursedirs=dist build .tox .eggs
-addopts=--doctest-modules
+addopts=--doctest-modules --flake8
doctest_optionflags=ALLOW_UNICODE ELLIPSIS
diff --git a/setup.py b/setup.py
index b96db52..9320edb 100644
--- a/setup.py
+++ b/setup.py
@@ -35,15 +35,22 @@ params = dict(
],
extras_require={
'testing': [
+ # upstream
'pytest>=2.8',
'pytest-sugar>=0.9.1',
'collective.checkdocs',
+ 'pytest-flake8',
+
+ # local
'pytest-virtualenv',
],
'docs': [
+ # upstream
'sphinx',
'jaraco.packaging>=3.2',
'rst.linker>=1.9',
+
+ # local
],
},
setup_requires=[
diff --git a/tox.ini b/tox.ini
index df1b0ef..c2bac45 100644
--- a/tox.ini
+++ b/tox.ini
@@ -5,6 +5,8 @@ minversion = 2.4
[testenv]
deps =
setuptools>=31.0.1
+ # workaround for yaml/pyyaml#126
+ # git+https://github.com/yaml/pyyaml@master#egg=pyyaml;python_version=="3.7"
commands =
py.test {posargs}
python setup.py checkdocs