summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNils Werner <nils.werner@gmail.com>2017-01-31 15:29:00 +0100
committerJason R. Coombs <jaraco@jaraco.com>2017-01-31 09:29:00 -0500
commitbd7d9094669ef9dbfd37f8faa59b2c849c8db515 (patch)
treed43a66b625da291794b1cb8e0cb7a29aa2a1e9bf
parentce5a9260dd3821270d0000b1a15aa73b65838789 (diff)
downloadpytest-runner-bd7d9094669ef9dbfd37f8faa59b2c849c8db515.tar.gz
Rephrased usage section a bit (#27)
-rw-r--r--README.rst16
1 files changed, 8 insertions, 8 deletions
diff --git a/README.rst b/README.rst
index 834fe6e..f315e6e 100644
--- a/README.rst
+++ b/README.rst
@@ -29,14 +29,14 @@ Usage
- Pass ``--index-url`` to have test requirements downloaded from an alternate
index URL (unnecessary if specified for easy_install in setup.cfg).
- Pass additional py.test command-line options using ``--addopts``.
-- Set permanent options for the pytest distutils command in the ``[pytest]``
- section of setup.cfg.
-- Set permanent options for the pytest run itself in the ``[pytest]``
- section of pytest.ini or tox.ini. See `pytest 567
- <https://bitbucket.org/pytest-dev/pytest/issues/567/>`_ for details on
- why setup.cfg is inadequate.
-- Optionally, set ``test=pytest`` in the ``[aliases]`` section of setup.cfg
- to cause ``setup.py test`` to invoke pytest.
+- Set permanent options for the ``python setup.py pytest`` command (like ``index-url``)
+ in the ``[pytest]`` section of ``setup.cfg``.
+- Set permanent options for the ``py.test`` run (like ``addopts`` or ``pep8ignore``) in the ``[pytest]``
+ section of ``pytest.ini`` or ``tox.ini`` or put them in the ``[tool:pytest]``
+ section of ``setup.cfg``. See `pytest issue 567
+ <https://bitbucket.org/pytest-dev/pytest/issues/567/>`_.
+- Optionally, set ``test=pytest`` in the ``[aliases]`` section of ``setup.cfg``
+ to cause ``python setup.py test`` to invoke pytest.
Example
-------