summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason R. Coombs <jaraco@jaraco.com>2017-01-20 11:19:29 -0500
committerJason R. Coombs <jaraco@jaraco.com>2017-01-20 11:19:29 -0500
commitce5a9260dd3821270d0000b1a15aa73b65838789 (patch)
tree23616b05ed43da7ddd75c31898e90f209160a89c
parentdc04e99cfb8c23747b91ff9155b45074149faae7 (diff)
parent9f6eea591eaae483be11d13ebad06958a6a1e2c8 (diff)
downloadpytest-runner-ce5a9260dd3821270d0000b1a15aa73b65838789.tar.gz
Merge skeleton
-rw-r--r--.travis.yml5
-rw-r--r--README.rst10
-rw-r--r--docs/conf.py20
-rw-r--r--setup.cfg3
-rw-r--r--setup.py10
5 files changed, 20 insertions, 28 deletions
diff --git a/.travis.yml b/.travis.yml
index 38ff1f3..78eb2de 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -2,7 +2,7 @@ sudo: false
language: python
python:
- 2.7
-- 3.5
+- 3.6
install:
- pip install tox "setuptools>=28.2"
script:
@@ -16,8 +16,9 @@ deploy:
on:
tags: true
all_branches: true
- python: 3.5
+ python: 3.6
user: jaraco
distributions: dists
+ skip_upload_docs: true
password:
secure: lZfYQx0ZrCf2FJ+348etKWfzTySB3BZYGd0ce5RFHN2BppcdkONyJfTs4rgdrFEn/WtOaKV3SkJYR09xvlr+4kbLibg7fXhueqZt0ZkhRBnoDE4SxCjICyFCmisG6O3zkrVosizch70/0MqseNanhgXOPhd5llCfQHIqLsa145BG4hM5kxAHPO3Rz2/HCObOTPe4HKj93RAK7lPIMZVN6omcWoG6ZB0QqK+i3LTUtmJ3gE6q/iHk3VF9cJs8xtn3hdo++Lhrboa2NIqf6fl8oxR1C24Wh8vBQ69uTNjmVnDFYMulTs5475jjgDBXPPgVz3CAqYAy/PI+NPw59ebK8MzlaMRK/h/xSrdhxW6K3WbBL71Dn2UGuejXHFC3IuCI832xwkuEupOcGLWz4r2uBnhbgXF63vZ2gYPqrCGHxvDpbtllTVyEeebP8BnFzZttxSn9rbhTP1O9Dn/9tRko8WskyXIR+/2JOA9KP5uT47yeHoFBBUS0GB1XdkGhBrJfQx2LhfHuI6bpzosMiMfJrVNZEg8k0I9XA0uwxDgZrdqKGMKBR6233MXiJg8NyUPRInCRGth4rufcq6kn+wsT9RvuSt9XOhGiYLwChjvHexUXrLGBgupu0Y80Oqcp3YkDG3WHUX++Z2zJSQovrb4BMdKS6Y4usQ8Df5SklIpMCf0=
diff --git a/README.rst b/README.rst
index c639b00..834fe6e 100644
--- a/README.rst
+++ b/README.rst
@@ -19,16 +19,6 @@ License is indicated in the project metadata (typically one or more
of the Trove classifiers). For more details, see `this explanation
<https://github.com/jaraco/skeleton/issues/1>`_.
-Docs
-====
-
-There's `no good mechanism for publishing documentation
-<https://github.com/pypa/python-packaging-user-guide/pull/266>`_
-easily. If there's a documentation link above, it's probably
-stale because PyPI-based documentation is deprecated. This
-project may have documentation published at ReadTheDocs, but
-probably not. Good luck finding it.
-
Usage
-----
diff --git a/docs/conf.py b/docs/conf.py
index 2b17634..2d86231 100644
--- a/docs/conf.py
+++ b/docs/conf.py
@@ -1,7 +1,9 @@
#!/usr/bin/env python3
# -*- coding: utf-8 -*-
-import pkg_resources
+import os
+import sys
+import subprocess
extensions = [
'sphinx.ext.autodoc',
@@ -9,11 +11,16 @@ extensions = [
]
# General information about the project.
-project = 'pytest-runner'
-copyright = '2015,2016 Jason R. Coombs'
-# The short X.Y version.
-version = pkg_resources.require(project)[0].version
+root = os.path.join(os.path.dirname(__file__), '..')
+setup_script = os.path.join(root, 'setup.py')
+fields = ['--name', '--version', '--url', '--author']
+dist_info_cmd = [sys.executable, setup_script] + fields
+output_bytes = subprocess.check_output(dist_info_cmd, cwd=root)
+project, version, url, author = output_bytes.decode('utf-8').strip().split('\n')
+
+copyright = '2015-2017 ' + author
+
# The full version, including alpha/beta/rc tags.
release = version
@@ -24,11 +31,12 @@ link_files = {
using=dict(
GH='https://github.com',
project=project,
+ url=url,
),
replace=[
dict(
pattern=r"(Issue )?#(?P<issue>\d+)",
- url='{GH}/pytest-dev/{project}/issues/{issue}',
+ url='{url}/issues/{issue}',
),
dict(
pattern=r"^(?m)((?P<scm_version>v?\d+(\.\d+){1,2}))\n[-=]+\n",
diff --git a/setup.cfg b/setup.cfg
index 4659acc..e080324 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -4,6 +4,3 @@ dists = clean --all sdist bdist_wheel
[wheel]
universal = 1
-
-[upload]
-repository = https://upload.pypi.org/legacy/
diff --git a/setup.py b/setup.py
index 3600f92..f587434 100644
--- a/setup.py
+++ b/setup.py
@@ -3,20 +3,16 @@
# Project skeleton maintained at https://github.com/jaraco/skeleton
import io
-import sys
import setuptools
with io.open('README.rst', encoding='utf-8') as readme:
long_description = readme.read()
-needs_wheel = set(['release', 'bdist_wheel', 'dists']).intersection(sys.argv)
-wheel = ['wheel'] if needs_wheel else []
-
name = 'pytest-runner'
description = 'Invoke py.test as distutils command with dependency resolution'
-setup_params = dict(
+params = dict(
name=name,
use_scm_version=True,
author="Jason R. Coombs",
@@ -32,7 +28,7 @@ setup_params = dict(
},
setup_requires=[
'setuptools_scm>=1.15.0',
- ] + wheel,
+ ],
classifiers=[
"Development Status :: 5 - Production/Stable",
"Intended Audience :: Developers",
@@ -50,4 +46,4 @@ setup_params = dict(
},
)
if __name__ == '__main__':
- setuptools.setup(**setup_params)
+ setuptools.setup(**params)