summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason R. Coombs <jaraco@jaraco.com>2016-12-07 14:40:58 -0500
committerJason R. Coombs <jaraco@jaraco.com>2016-12-07 14:40:58 -0500
commiteb4323e94eb443cdc301c01a0f7b819891ff7234 (patch)
tree259e1faf30a1ba77caf771ee8b78d93ed045f2a1
parent5dadfb7d2bff10b488756ae5fd8cb5988235882d (diff)
parent18cb65f8f1c1eaf7b79a33fb5a2b7cbd1f851868 (diff)
downloadpytest-runner-eb4323e94eb443cdc301c01a0f7b819891ff7234.tar.gz
Merge with updated skeleton
-rw-r--r--.travis.yml2
-rw-r--r--README.rst14
-rw-r--r--docs/conf.py2
-rw-r--r--docs/requirements.txt1
-rw-r--r--setup.py2
5 files changed, 17 insertions, 4 deletions
diff --git a/.travis.yml b/.travis.yml
index a46869e..8b38b9a 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -10,8 +10,6 @@ script:
branches:
except:
- skeleton
-before_deploy:
-- pip install https://dl.dropboxusercontent.com/u/54081/cheeseshop/setuptools_scm-1.15.0rc1.tar.gz
deploy:
provider: pypi
server: https://upload.pypi.org/legacy/
diff --git a/README.rst b/README.rst
index 2af13f4..c639b00 100644
--- a/README.rst
+++ b/README.rst
@@ -11,10 +11,24 @@
Setup scripts can use pytest-runner to add setup.py test support for pytest
runner.
+
+License
+=======
+
License is indicated in the project metadata (typically one or more
of the Trove classifiers). For more details, see `this explanation
<https://github.com/jaraco/skeleton/issues/1>`_.
+Docs
+====
+
+There's `no good mechanism for publishing documentation
+<https://github.com/pypa/python-packaging-user-guide/pull/266>`_
+easily. If there's a documentation link above, it's probably
+stale because PyPI-based documentation is deprecated. This
+project may have documentation published at ReadTheDocs, but
+probably not. Good luck finding it.
+
Usage
-----
diff --git a/docs/conf.py b/docs/conf.py
index fe7c018..2b17634 100644
--- a/docs/conf.py
+++ b/docs/conf.py
@@ -20,7 +20,7 @@ release = version
master_doc = 'index'
link_files = {
- 'CHANGES.rst': dict(
+ '../CHANGES.rst': dict(
using=dict(
GH='https://github.com',
project=project,
diff --git a/docs/requirements.txt b/docs/requirements.txt
new file mode 100644
index 0000000..442df9f
--- /dev/null
+++ b/docs/requirements.txt
@@ -0,0 +1 @@
+rst.linker
diff --git a/setup.py b/setup.py
index b0547f6..3600f92 100644
--- a/setup.py
+++ b/setup.py
@@ -31,7 +31,7 @@ setup_params = dict(
extras_require={
},
setup_requires=[
- 'setuptools_scm>=1.9,!=1.13.1,!=1.14.0',
+ 'setuptools_scm>=1.15.0',
] + wheel,
classifiers=[
"Development Status :: 5 - Production/Stable",