summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Grainger <tagrain@gmail.com>2019-08-27 10:29:24 +0100
committerGitHub <noreply@github.com>2019-08-27 10:29:24 +0100
commit78a492cb9f611a4fccaf6556c966b848885833ba (patch)
treef34bfa5ce86a861f087be215359463f89bf6d7d3
parent8437c7f898e4400b0d45ef4e6d9b584ea2580780 (diff)
downloadpytest-runner-78a492cb9f611a4fccaf6556c966b848885833ba.tar.gz
Add deprecation notice Fixes #50
-rw-r--r--README.rst15
1 files changed, 15 insertions, 0 deletions
diff --git a/README.rst b/README.rst
index 879e84a..99b00af 100644
--- a/README.rst
+++ b/README.rst
@@ -19,6 +19,21 @@
Setup scripts can use pytest-runner to add setup.py test support for pytest
runner.
+Deprecation Notice
+==================
+
+pytest-runner depends on deprecated features of setuptools and relys on features that break security
+mechanisms in pip. For example `setup_requires` and `tests_require` bypass `pip --require-hashes`.
+See also https://github.com/pypa/setuptools/issues/1684.
+
+It is recommended that you:
+
+- Remove 'pytest-runner' from your 'setup_requires', preferably removing the `setup_requires` option.
+- Remove 'pytest' and any other testing requirements from 'tests_require', preferably removing the `setup_requires` option.
+- Use a requirement-test.txt file to hold test dependencies
+- Invoke tests with ``pytest``
+- Another good option is to configure a ``tox.ini`` next to your ``setup.cfg`` https://tox.readthedocs.io/en/latest/
+
Usage
=====