summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason R. Coombs <jaraco@jaraco.com>2019-10-26 17:52:30 -0400
committerGitHub <noreply@github.com>2019-10-26 17:52:30 -0400
commitcd4ea07d264e9ed914cd0dcdfaa29df09e6587c2 (patch)
treec3a2df8eb4dbe41237588da9a12dd026f9aafe8f
parent8437c7f898e4400b0d45ef4e6d9b584ea2580780 (diff)
parentbb31ecebd6e95b336bbd2b094dc9753125c98387 (diff)
downloadpytest-runner-cd4ea07d264e9ed914cd0dcdfaa29df09e6587c2.tar.gz
Merge pull request #52 from pytest-dev/graingert-patch-1
Add deprecation notice Fixes #50
-rw-r--r--README.rst13
1 files changed, 13 insertions, 0 deletions
diff --git a/README.rst b/README.rst
index 879e84a..0a400aa 100644
--- a/README.rst
+++ b/README.rst
@@ -19,6 +19,19 @@
Setup scripts can use pytest-runner to add setup.py test support for pytest
runner.
+Deprecation Notice
+==================
+
+pytest-runner depends on deprecated features of setuptools and relies on features that break security
+mechanisms in pip. For example 'setup_requires' and 'tests_require' bypass ``pip --require-hashes``.
+See also https://github.com/pypa/setuptools/issues/1684.
+
+It is recommended that you:
+
+- Remove 'pytest-runner' from your 'setup_requires', preferably removing the `setup_requires` option.
+- Remove 'pytest' and any other testing requirements from 'tests_require', preferably removing the `setup_requires` option.
+- Select a tool to bootstrap and then run tests such as tox
+
Usage
=====