summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason R. Coombs <jaraco@jaraco.com>2012-05-06 14:50:55 -0400
committerJason R. Coombs <jaraco@jaraco.com>2012-05-06 14:50:55 -0400
commit289d9f1afa892074149688886319cf3ff773aeab (patch)
tree5e91e47f1e4691a69d8d0801c96dddc7d2b67082
parent0923605da882c8a1eaa7a6fd4419321ee9c86541 (diff)
downloadpytest-runner-289d9f1afa892074149688886319cf3ff773aeab.tar.gz
Renamed module to ptr and eliminated unnecessary package1.0b1
-rw-r--r--ptr.py (renamed from pytest_runner/command.py)18
-rw-r--r--setup.py4
2 files changed, 17 insertions, 5 deletions
diff --git a/pytest_runner/command.py b/ptr.py
index a9481a7..1394d69 100644
--- a/pytest_runner/command.py
+++ b/ptr.py
@@ -3,9 +3,21 @@ Setup scripts can use this to add setup.py test support for pytest runner.
Recommended usage:
-execfile('pytest-runner/command.py')
-setup_params = PyTest.install(dict(...))
-setuptools.setup(**setup_params)
+- add pytest-runner to your 'setup_requires'
+- include 'pytest' and any other testing requirements to 'tests_require'
+- invoke tests with setup.py ptr
+
+Alternate usage:
+
+- include this file (ptr.py) in your repo
+- add these lines to your setup.py::
+
+ execfile('ptr.py')
+ setup_params = PyTest.install(dict(...))
+ setuptools.setup(**setup_params)
+
+ Where '...' are your normal keyword parameters to setup()
+- invoke your tests with setup.py test
"""
import os as _os
diff --git a/setup.py b/setup.py
index 97af078..f9e12f9 100644
--- a/setup.py
+++ b/setup.py
@@ -8,11 +8,11 @@ setup_params = dict(
author="Jason R. Coombs",
author_email="jaraco@jaraco.com",
url="https://bitbucket.org/jaraco/pytest-runner",
- packages=setuptools.find_packages(),
+ py_modules = ['ptr'],
zip_safe=True,
entry_points = {
'distutils.commands':
- ['pytest_runner = pytest_runner.command:PyTest'],
+ ['ptr = ptr:PyTest'],
},
setup_requires=[
'hgtools',