summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason R. Coombs <jaraco@jaraco.com>2015-03-04 10:17:16 -0500
committerJason R. Coombs <jaraco@jaraco.com>2015-03-04 10:17:16 -0500
commit40e2519cb00d805961f1da10969da54a91cbcfcb (patch)
treef9c732c50ccf5a401b6639f0b7e2e400ac96b6f3
parent763f664887169c1d1bacde5f2f58c0bf3b2a93d3 (diff)
downloadpytest-runner-40e2519cb00d805961f1da10969da54a91cbcfcb.tar.gz
Restore Python 2.6 compatibility.2.5.1
-rw-r--r--CHANGES.txt5
-rw-r--r--setup.py4
2 files changed, 7 insertions, 2 deletions
diff --git a/CHANGES.txt b/CHANGES.txt
index 4bc8d80..ca6d069 100644
--- a/CHANGES.txt
+++ b/CHANGES.txt
@@ -1,3 +1,8 @@
+2.5.1
+~~~~~
+
+* Restore Python 2.6 compatibility.
+
2.5
~~~
diff --git a/setup.py b/setup.py
index e568ac2..7c6596b 100644
--- a/setup.py
+++ b/setup.py
@@ -10,9 +10,9 @@ import setuptools
with io.open('README.txt', encoding='utf-8') as readme:
long_description = readme.read()
-needs_pytest = {'pytest', 'test'}.intersection(sys.argv)
+needs_pytest = set(['pytest', 'test']).intersection(sys.argv)
pytest_runner = ['pytest-runner'] if needs_pytest else []
-needs_sphinx = {'release', 'build_sphinx', 'upload_docs'}.intersection(sys.argv)
+needs_sphinx = set(['release', 'build_sphinx', 'upload_docs']).intersection(sys.argv)
sphinx = ['sphinx'] if needs_sphinx else []
setup_params = dict(