summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason R. Coombs <jaraco@jaraco.com>2015-02-26 11:28:01 -0500
committerJason R. Coombs <jaraco@jaraco.com>2015-02-26 11:28:01 -0500
commit5d911074ba86c7aefa9c1a39741ca8268a7c4d11 (patch)
tree85760ae436b23ecce894236e16d2f53adaed0d84
parent8d7024936597d6a87c524f315406ae1421c87a91 (diff)
downloadpytest-runner-5d911074ba86c7aefa9c1a39741ca8268a7c4d11.tar.gz
Add inline example. Fixes #4
-rw-r--r--README17
1 files changed, 16 insertions, 1 deletions
diff --git a/README b/README
index 6247cff..c249394 100644
--- a/README
+++ b/README
@@ -26,9 +26,24 @@ Usage
Example
-------
+The most simple usage looks like this in setup.py::
+
+ setup(
+ setup_requires=[
+ 'pytest-runner',
+ ],
+ tests_require=[
+ 'pytest',
+ ],
+ )
+
+Additional dependencies require to run the tests (e.g. mock or pytest
+plugins) may be added to tests_require and will be downloaded and
+required by the session before invoking pytest.
+
See the `jaraco.collections
<https://bitbucket.org/jaraco/jaraco.collections/>`_ project
-for example usage.
+for real-world usage.
Considerations
--------------