summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason R. Coombs <jaraco@jaraco.com>2014-08-21 18:43:38 -0400
committerJason R. Coombs <jaraco@jaraco.com>2014-08-21 18:43:38 -0400
commit6402825e1656438d4c5deb636325da5084f124f4 (patch)
tree275299eacc1f1f35ea2fdaa110410ff9256314df
parentc9ab898dfb602fc1e04f94f126c01ccbcc9c0f92 (diff)
downloadpytest-runner-6402825e1656438d4c5deb636325da5084f124f4.tar.gz
Add pytest command. Ref #2.
-rw-r--r--README7
-rw-r--r--setup.py1
2 files changed, 7 insertions, 1 deletions
diff --git a/README b/README
index d2dcae5..e97a625 100644
--- a/README
+++ b/README
@@ -10,7 +10,7 @@ Usage
- Add 'pytest-runner' to your 'setup_requires'. Pin to '>=2.0,<3dev' (or
similar) to avoid pulling in incompatible versions.
- Include 'pytest' and any other testing requirements to 'tests_require'.
-- Invoke tests with `setup.py ptr`.
+- Invoke tests with `setup.py pytest`.
See the `jaraco.util <https://bitbucket.org/jaraco/jaraco.util/>`_ project
for an example.
@@ -18,6 +18,11 @@ for an example.
Changes
-------
+2.1
+~~~
+
+* The preferred invocation is now the 'pytest' command.
+
2.0
~~~
diff --git a/setup.py b/setup.py
index fcdba5f..8b6f115 100644
--- a/setup.py
+++ b/setup.py
@@ -13,6 +13,7 @@ setup_params = dict(
entry_points = {
'distutils.commands': [
'ptr = ptr:PyTest',
+ 'pytest = ptr:PyTest',
],
},
license = 'MIT',