summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason R. Coombs <jaraco@jaraco.com>2012-02-07 16:27:43 -0500
committerJason R. Coombs <jaraco@jaraco.com>2012-02-07 16:27:43 -0500
commit83c2b28ccd8f1939116628e09e4464f2b38a3f77 (patch)
tree28f6172514c94c0ceda1f453e4c6bd8d2684e4b2
parent5e90e2c790ee8fb87f7b53f9ff84d18bdf72a18a (diff)
downloadpytest-runner-83c2b28ccd8f1939116628e09e4464f2b38a3f77.tar.gz
Added support for returning the dict so the params can be constructed inline.
-rw-r--r--command.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/command.py b/command.py
index b4fe24f..8ce9a42 100644
--- a/command.py
+++ b/command.py
@@ -4,8 +4,7 @@ Setup scripts can use this to add setup.py test support for pytest runner.
Recommended usage:
execfile('pytest-runner/command.py')
-setup_params = dict(...)
-PyTest.install(setup_params)
+setup_params = PyTest.install(dict(...))
setuptools.setup(**setup_params)
"""
@@ -112,3 +111,4 @@ class PyTest(_pytest_runner_test.test):
setup_params.setdefault('cmdclass', {}).update(
test=cls,
)
+ return setup_params