summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason R. Coombs <jaraco@jaraco.com>2015-03-01 10:28:07 -0500
committerJason R. Coombs <jaraco@jaraco.com>2015-03-01 10:28:07 -0500
commit8cac0b2cb71073568c5a6e6187136837c3ded7f5 (patch)
tree579c62c3eed0acec67156296078ab81f9d344030
downloadpytest-runner-8cac0b2cb71073568c5a6e6187136837c3ded7f5.tar.gz
Adding project skeleton
-rw-r--r--.hgignore2
-rw-r--r--CHANGES.txt0
-rw-r--r--README.txt2
-rw-r--r--docs/conf.py22
-rw-r--r--docs/history.rst8
-rw-r--r--docs/index.rst22
-rw-r--r--pytest.ini3
-rw-r--r--setup.cfg3
-rw-r--r--setup.py46
9 files changed, 108 insertions, 0 deletions
diff --git a/.hgignore b/.hgignore
new file mode 100644
index 0000000..31e77e9
--- /dev/null
+++ b/.hgignore
@@ -0,0 +1,2 @@
+build
+dist
diff --git a/CHANGES.txt b/CHANGES.txt
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/CHANGES.txt
diff --git a/README.txt b/README.txt
new file mode 100644
index 0000000..d09d934
--- /dev/null
+++ b/README.txt
@@ -0,0 +1,2 @@
+`Documentation <https://pythonhosted.org/pytest-runner>`_pytest-runner
+=============
diff --git a/docs/conf.py b/docs/conf.py
new file mode 100644
index 0000000..12d03c6
--- /dev/null
+++ b/docs/conf.py
@@ -0,0 +1,22 @@
+#!/usr/bin/env python3
+# -*- coding: utf-8 -*-
+
+import hgtools.managers
+
+# use hgtools to get the version
+hg_mgr = hgtools.managers.RepoManager.get_first_valid_manager()
+
+extensions = [
+ 'sphinx.ext.autodoc',
+]
+
+# General information about the project.
+project = 'pytest-runner'
+copyright = '2015 Jason R. Coombs'
+
+# The short X.Y version.
+version = hg_mgr.get_current_version()
+# The full version, including alpha/beta/rc tags.
+release = version
+
+master_doc = 'index'
diff --git a/docs/history.rst b/docs/history.rst
new file mode 100644
index 0000000..db85fec
--- /dev/null
+++ b/docs/history.rst
@@ -0,0 +1,8 @@
+:tocdepth: 2
+
+.. _changes:
+
+History
+*******
+
+.. include:: ../CHANGES.txt
diff --git a/docs/index.rst b/docs/index.rst
new file mode 100644
index 0000000..6b8d791
--- /dev/null
+++ b/docs/index.rst
@@ -0,0 +1,22 @@
+Welcome to pytest-runner documentation!
+========================================
+
+.. toctree::
+ :maxdepth: 1
+
+ history
+
+
+.. automodule:: pytest-runner
+ :members:
+ :undoc-members:
+ :show-inheritance:
+
+
+Indices and tables
+==================
+
+* :ref:`genindex`
+* :ref:`modindex`
+* :ref:`search`
+
diff --git a/pytest.ini b/pytest.ini
new file mode 100644
index 0000000..f38e724
--- /dev/null
+++ b/pytest.ini
@@ -0,0 +1,3 @@
+[pytest]
+norecursedirs=*.egg .eggs dist build
+addopts=--doctest-modules
diff --git a/setup.cfg b/setup.cfg
new file mode 100644
index 0000000..e3b1c8b
--- /dev/null
+++ b/setup.cfg
@@ -0,0 +1,3 @@
+[aliases]
+release = sdist build_sphinx upload upload_docs
+test = pytest
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..ac40a89
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,46 @@
+#!/usr/bin/env python
+# Generated by jaraco.develop 2.14
+# https://pypi.python.org/pypi/jaraco.develop
+
+import io
+import sys
+
+import setuptools
+
+with io.open('README.txt', encoding='utf-8') as readme:
+ long_description = readme.read()
+
+needs_pytest = {'pytest', 'test'}.intersection(sys.argv)
+pytest_runner = ['pytest_runner'] if needs_pytest else []
+needs_sphinx = {'release', 'build_sphinx', 'upload_docs'}.intersection(sys.argv)
+sphinx = ['sphinx'] if needs_sphinx else []
+
+setup_params = dict(
+ name='pytest-runner',
+ use_scm_version=True,
+ author="Jason R. Coombs",
+ author_email="jaraco@jaraco.com",
+ description="pytest-runner",
+ long_description=long_description,
+ url="https://bitbucket.org/jaraco/pytest-runner",
+ packages=setuptools.find_packages(),
+ namespace_packages=[''],
+ install_requires=[
+ ],
+ setup_requires=[
+ 'setuptools_scm',
+ ] + pytest_runner + sphinx,
+ tests_require=[
+ 'pytest',
+ ],
+ license='MIT',
+ classifiers=[
+ "Development Status :: 5 - Production/Stable",
+ "Intended Audience :: Developers",
+ "License :: OSI Approved :: MIT License",
+ "Programming Language :: Python :: 2.7",
+ "Programming Language :: Python :: 3",
+ ],
+)
+if __name__ == '__main__':
+ setuptools.setup(**setup_params)