summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason R. Coombs <jaraco@jaraco.com>2016-09-14 21:00:50 -0400
committerJason R. Coombs <jaraco@jaraco.com>2016-09-14 21:00:50 -0400
commit03c1cc86843bcfbb6c2a9366d285427ac006aeee (patch)
tree0a581c10ae7607c36d5c8d9d1b99278d2f977980
parent629d80f45dedc801e3fe19215ba50114b4c7b949 (diff)
downloadpytest-runner-03c1cc86843bcfbb6c2a9366d285427ac006aeee.tar.gz
Remove support for building docs, now that docs support for pypi is deprecated. I hope at some point RTD comes up with an API that once again allows automatic building of docs.
-rw-r--r--setup.cfg2
-rw-r--r--setup.py6
2 files changed, 3 insertions, 5 deletions
diff --git a/setup.cfg b/setup.cfg
index dcd8d12..f5ee607 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,5 +1,5 @@
[aliases]
-release = dists build_sphinx upload upload_docs
+release = dists upload
dists = clean --all sdist bdist_wheel
test = pytest
diff --git a/setup.py b/setup.py
index 91e4110..1f815f2 100644
--- a/setup.py
+++ b/setup.py
@@ -12,9 +12,7 @@ with io.open('README.rst', encoding='utf-8') as readme:
needs_pytest = {'pytest', 'test'}.intersection(sys.argv)
pytest_runner = ['pytest_runner'] if needs_pytest else []
-needs_sphinx = {'release', 'build_sphinx', 'upload_docs'}.intersection(sys.argv)
-sphinx = ['sphinx', 'rst.linker'] if needs_sphinx else []
-needs_wheel = {'release', 'bdist_wheel'}.intersection(sys.argv)
+needs_wheel = {'release', 'bdist_wheel', 'dists'}.intersection(sys.argv)
wheel = ['wheel'] if needs_wheel else []
name = 'skeleton'
@@ -37,7 +35,7 @@ setup_params = dict(
},
setup_requires=[
'setuptools_scm>=1.9',
- ] + pytest_runner + sphinx + wheel,
+ ] + pytest_runner + wheel,
tests_require=[
'pytest>=2.8',
],