summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason R. Coombs <jaraco@jaraco.com>2016-09-22 10:50:07 -0500
committerJason R. Coombs <jaraco@jaraco.com>2016-09-22 10:50:07 -0500
commit750a2b38964adc868b1a7f4570afa1532418b12c (patch)
tree5fef50d62dd7a3679c30c797f1f4373d0f0a95a5
parent03c1cc86843bcfbb6c2a9366d285427ac006aeee (diff)
downloadpytest-runner-750a2b38964adc868b1a7f4570afa1532418b12c.tar.gz
Use tox instead of pytest-runner
-rw-r--r--.travis.yml3
-rw-r--r--pytest.ini2
-rw-r--r--setup.cfg1
-rw-r--r--setup.py7
-rw-r--r--tests/requirements.txt1
-rw-r--r--tox.ini5
6 files changed, 9 insertions, 10 deletions
diff --git a/.travis.yml b/.travis.yml
index 9f4c517..6c9a2cf 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -4,8 +4,7 @@ python:
- 2.7
- 3.5
script:
-- pip install -U pytest
-- python setup.py test
+- tox
branches:
except:
- skeleton
diff --git a/pytest.ini b/pytest.ini
index 9752c36..56a8774 100644
--- a/pytest.ini
+++ b/pytest.ini
@@ -1,4 +1,4 @@
[pytest]
-norecursedirs=*.egg .eggs dist build
+norecursedirs=dist build .tox
addopts=--doctest-modules
doctest_optionflags=ALLOW_UNICODE ELLIPSIS
diff --git a/setup.cfg b/setup.cfg
index f5ee607..4659acc 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,7 +1,6 @@
[aliases]
release = dists upload
dists = clean --all sdist bdist_wheel
-test = pytest
[wheel]
universal = 1
diff --git a/setup.py b/setup.py
index 1f815f2..ec848c1 100644
--- a/setup.py
+++ b/setup.py
@@ -10,8 +10,6 @@ import setuptools
with io.open('README.rst', encoding='utf-8') as readme:
long_description = readme.read()
-needs_pytest = {'pytest', 'test'}.intersection(sys.argv)
-pytest_runner = ['pytest_runner'] if needs_pytest else []
needs_wheel = {'release', 'bdist_wheel', 'dists'}.intersection(sys.argv)
wheel = ['wheel'] if needs_wheel else []
@@ -35,10 +33,7 @@ setup_params = dict(
},
setup_requires=[
'setuptools_scm>=1.9',
- ] + pytest_runner + wheel,
- tests_require=[
- 'pytest>=2.8',
- ],
+ ] + wheel,
classifiers=[
"Development Status :: 5 - Production/Stable",
"Intended Audience :: Developers",
diff --git a/tests/requirements.txt b/tests/requirements.txt
new file mode 100644
index 0000000..70bc02f
--- /dev/null
+++ b/tests/requirements.txt
@@ -0,0 +1 @@
+pytest >= 2.8
diff --git a/tox.ini b/tox.ini
new file mode 100644
index 0000000..dea8374
--- /dev/null
+++ b/tox.ini
@@ -0,0 +1,5 @@
+[testenv]
+deps =
+ -r tests/requirements.txt
+
+commands = py.test