summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason R. Coombs <jaraco@jaraco.com>2016-04-02 21:46:39 -0400
committerJason R. Coombs <jaraco@jaraco.com>2016-04-02 21:46:39 -0400
commit752b1096b8d126df040847c19c82aa042ccfe77a (patch)
tree0e9619f43ab757e16eacb1c0e48e48fcfc9aa187
parent65b649869bb4f0ab1aad5deb3a30973a45082d4a (diff)
downloadpytest-runner-752b1096b8d126df040847c19c82aa042ccfe77a.tar.gz
Add PyPI deployment
-rw-r--r--.travis.yml18
1 files changed, 14 insertions, 4 deletions
diff --git a/.travis.yml b/.travis.yml
index 6e5e969..a5b29ee 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,8 +1,18 @@
sudo: false
language: python
python:
- - 2.7
- - 3.5
+- 2.7
+- 3.5
script:
- - pip install -U pytest
- - python setup.py test
+- pip install -U pytest
+- python setup.py test
+deploy:
+ provider: pypi
+ on:
+ tags: true
+ all_branches: true
+ user: jaraco
+ provider: pypi
+ # supply password with `travis encrypt --add deploy.password`
+ distributions: release
+ python: 3.5