summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason R. Coombs <jaraco@jaraco.com>2016-12-23 08:57:20 -0500
committerJason R. Coombs <jaraco@jaraco.com>2016-12-23 08:57:20 -0500
commitb1133de832c3960777b9db80c070885c4bedd7c4 (patch)
tree5afd3f0eee9f3901038af233a5e9a9822806499a
parentb2c592d84bc5f7c16a70b6d593fb320c5559eeee (diff)
downloadpytest-runner-b1133de832c3960777b9db80c070885c4bedd7c4.tar.gz
Strip the trailing newline and then split on newline.
-rw-r--r--docs/conf.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/docs/conf.py b/docs/conf.py
index 23a2447..7402f72 100644
--- a/docs/conf.py
+++ b/docs/conf.py
@@ -17,7 +17,7 @@ setup_script = os.path.join(root, 'setup.py')
fields = ['--name', '--version', '--url', '--author']
dist_info_cmd = [sys.executable, setup_script] + fields
output_bytes = subprocess.check_output(dist_info_cmd, cwd=root)
-project, version, url, author = output_bytes.decode('utf-8').split()
+project, version, url, author = output_bytes.decode('utf-8').strip().split('\n')
copyright = '2016 ' + author