summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason R. Coombs <jaraco@jaraco.com>2016-12-23 08:44:55 -0500
committerJason R. Coombs <jaraco@jaraco.com>2016-12-23 08:44:55 -0500
commitfbadf0344d4b9ac6917e8546b5529c20082f4733 (patch)
treef2363e1540fc9c8e799824bfcf84e2876f77336b
parent3da8cf4a6f14abf5da05c9d46f3362dcc43d71a4 (diff)
downloadpytest-runner-fbadf0344d4b9ac6917e8546b5529c20082f4733.tar.gz
Also get the URL from the project metadata
-rw-r--r--docs/conf.py7
1 files changed, 4 insertions, 3 deletions
diff --git a/docs/conf.py b/docs/conf.py
index adc9df7..d52e40d 100644
--- a/docs/conf.py
+++ b/docs/conf.py
@@ -14,9 +14,9 @@ extensions = [
root = os.path.join(os.path.dirname(__file__), '..')
setup_script = os.path.join(root, 'setup.py')
-dist_info_cmd = [sys.executable, setup_script, '--name', '--version']
+dist_info_cmd = [sys.executable, setup_script, '--name', '--version', '--url']
output_bytes = subprocess.check_output(dist_info_cmd, cwd=root)
-project, version = output_bytes.decode('utf-8').split()
+project, version, url = output_bytes.decode('utf-8').split()
copyright = '2016 Jason R. Coombs'
@@ -30,11 +30,12 @@ link_files = {
using=dict(
GH='https://github.com',
project=project,
+ url=url,
),
replace=[
dict(
pattern=r"(Issue )?#(?P<issue>\d+)",
- url='{GH}/jaraco/{project}/issues/{issue}',
+ url='{url}/issues/{issue}',
),
dict(
pattern=r"^(?m)((?P<scm_version>v?\d+(\.\d+){1,2}))\n[-=]+\n",