summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason R. Coombs <jaraco@jaraco.com>2021-07-16 09:32:49 -0400
committerJason R. Coombs <jaraco@jaraco.com>2021-07-16 09:32:49 -0400
commit32daab966f8120dd8a46cfff3fd896de57f6a211 (patch)
tree3d9b2ed8b3e25cb2935ef9999064f0eb81a6b92f
parenta8fc8ddc5c22b9830a6209afc5c91847ccc171ac (diff)
parent498b965a805224420c8cde5969bf342a41766227 (diff)
downloadpytest-runner-32daab966f8120dd8a46cfff3fd896de57f6a211.tar.gz
Merge https://github.com/jaraco/skeleton
-rw-r--r--.github/workflows/main.yml5
-rw-r--r--pyproject.toml2
-rw-r--r--pytest.ini4
-rw-r--r--setup.cfg15
-rw-r--r--tox.ini3
5 files changed, 16 insertions, 13 deletions
diff --git a/.github/workflows/main.yml b/.github/workflows/main.yml
index 6a8ff00..7d6b455 100644
--- a/.github/workflows/main.yml
+++ b/.github/workflows/main.yml
@@ -6,7 +6,10 @@ jobs:
test:
strategy:
matrix:
- python: [3.6, 3.8, 3.9]
+ python:
+ - 3.6
+ - 3.9
+ - 3.10.0-alpha - 3.10.99
platform: [ubuntu-latest, macos-latest, windows-latest]
runs-on: ${{ matrix.platform }}
steps:
diff --git a/pyproject.toml b/pyproject.toml
index b6ebc0b..28bd788 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,5 +1,5 @@
[build-system]
-requires = ["setuptools>=42", "wheel", "setuptools_scm[toml]>=3.4.1"]
+requires = ["setuptools>=56", "wheel", "setuptools_scm[toml]>=3.4.1"]
build-backend = "setuptools.build_meta"
[tool.black]
diff --git a/pytest.ini b/pytest.ini
index 6bf69af..31b114f 100644
--- a/pytest.ini
+++ b/pytest.ini
@@ -5,3 +5,7 @@ doctest_optionflags=ALLOW_UNICODE ELLIPSIS
# workaround for warning pytest-dev/pytest#6178
junit_family=xunit2
filterwarnings=
+ # Suppress deprecation warning in flake8
+ ignore:SelectableGroups dict interface is deprecated::flake8
+ # Suppress deprecation warning in pypa/packaging#433
+ ignore:The distutils package is deprecated::packaging.tags
diff --git a/setup.cfg b/setup.cfg
index 57ba2f7..14bff40 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,6 +1,4 @@
[metadata]
-license_files =
- LICENSE
name = pytest-runner
author = Jason R. Coombs
author_email = jaraco@jaraco.com
@@ -22,7 +20,6 @@ include_package_data = true
python_requires = >=3.6
install_requires =
# setuptools 27.3 is required at run time
-setup_requires = setuptools_scm[toml] >= 3.4.1
[options.packages.find]
exclude =
@@ -37,13 +34,13 @@ testing =
pytest >= 4.6
pytest-checkdocs >= 2.4
pytest-flake8
- # python_implementation: workaround for jaraco/skeleton#22
- # python_version: workaround for python/typed_ast#156
- pytest-black >= 0.3.7; python_implementation != "PyPy" and python_version < "3.10"
+ pytest-black >= 0.3.7; \
+ # workaround for jaraco/skeleton#22
+ python_implementation != "PyPy"
pytest-cov
- # python_implementation: workaround for jaraco/skeleton#22
- # python_version: workaround for python/typed_ast#156
- pytest-mypy; python_implementation != "PyPy" and python_version < "3.10"
+ pytest-mypy; \
+ # workaround for jaraco/skeleton#22
+ python_implementation != "PyPy"
pytest-enabler >= 1.0.1
# local
diff --git a/tox.ini b/tox.ini
index 6984890..3ca2af3 100644
--- a/tox.ini
+++ b/tox.ini
@@ -26,7 +26,6 @@ skip_install = True
deps =
build
twine>=3
- path
jaraco.develop>=7.1
passenv =
TWINE_PASSWORD
@@ -34,7 +33,7 @@ passenv =
setenv =
TWINE_USERNAME = {env:TWINE_USERNAME:__token__}
commands =
- python -c "import path; path.Path('dist').rmtree_p()"
+ python -c "import shutil; shutil.rmtree('dist', ignore_errors=True)"
python -m build
python -m twine upload dist/*
python -m jaraco.develop.create-github-release