summaryrefslogtreecommitdiff
path: root/README.rst
diff options
context:
space:
mode:
authorJason R. Coombs <jaraco@jaraco.com>2018-02-10 14:59:40 -0500
committerJason R. Coombs <jaraco@jaraco.com>2018-02-10 15:00:42 -0500
commitb11624dea5b6337e442f0103c9b2f1bdd44b2995 (patch)
tree799d9baeab82bfbbd0fb0d3899aa848f89d6f255 /README.rst
parent95f4e9fbd57add2505f0325bd53246389f46006c (diff)
downloadpytest-runner-b11624dea5b6337e442f0103c9b2f1bdd44b2995.tar.gz
Use === for separator in changelog and readme, matching convention in other projects.
Diffstat (limited to 'README.rst')
-rw-r--r--README.rst10
1 files changed, 5 insertions, 5 deletions
diff --git a/README.rst b/README.rst
index 0395be7..2ad0825 100644
--- a/README.rst
+++ b/README.rst
@@ -13,7 +13,7 @@ Setup scripts can use pytest-runner to add setup.py test support for pytest
runner.
Usage
------
+=====
- Add 'pytest-runner' to your 'setup_requires'. Pin to '>=2.0,<3dev' (or
similar) to avoid pulling in incompatible versions.
@@ -32,7 +32,7 @@ Usage
to cause ``python setup.py test`` to invoke pytest.
Example
--------
+=======
The most simple usage looks like this in setup.py::
@@ -54,7 +54,7 @@ Follow `this search on github
for examples of real-world usage.
Standalone Example
-------------------
+==================
This technique is deprecated - if you have standalone scripts
you wish to invoke with dependencies, `use rwt
@@ -87,10 +87,10 @@ As a result, the communication barrier for describing and
replicating failures is made almost trivially low.
Considerations
---------------
+==============
Conditional Requirement
-~~~~~~~~~~~~~~~~~~~~~~~
+-----------------------
Because it uses Setuptools setup_requires, pytest-runner will install itself
on every invocation of setup.py. In some cases, this causes delays for