summaryrefslogtreecommitdiff
path: root/README
diff options
context:
space:
mode:
authorJason R. Coombs <jaraco@jaraco.com>2013-05-18 10:06:40 -0400
committerJason R. Coombs <jaraco@jaraco.com>2013-05-18 10:06:40 -0400
commita2043b0816f584b63cd10448f780bd5a6325e214 (patch)
treea73dbe68c26aab1e7d8a8cd09b827bc54f59807b /README
parentc199ca540c2046b8c9eb54f84ca2082a7a14fc9a (diff)
downloadpytest-runner-a2043b0816f584b63cd10448f780bd5a6325e214.tar.gz
Removed deprecated functionality2.0
Diffstat (limited to 'README')
-rw-r--r--README30
1 files changed, 14 insertions, 16 deletions
diff --git a/README b/README
index c72e057..d2dcae5 100644
--- a/README
+++ b/README
@@ -4,31 +4,29 @@ pytest-runner
Setup scripts can use pytest-runner to add setup.py test support for pytest
runner.
-Recommended usage
------------------
+Usage
+-----
-- Add 'pytest-runner' to your 'setup_requires'. Pin to '>=1.0,<2.0dev' (or
+- Add 'pytest-runner' to your 'setup_requires'. Pin to '>=2.0,<3dev' (or
similar) to avoid pulling in incompatible versions.
- Include 'pytest' and any other testing requirements to 'tests_require'.
- Invoke tests with `setup.py ptr`.
-Alternate usage
----------------
-
-- Include the file `ptr.py` in your repo.
-- Add these lines to your setup.py::
-
- execfile('ptr.py')
- setup_params = PyTest.install(dict(...))
- setuptools.setup(**setup_params)
-
- Where '...' are your normal keyword parameters to setup().
-
-- Invoke your tests with setup.py test.
+See the `jaraco.util <https://bitbucket.org/jaraco/jaraco.util/>`_ project
+for an example.
Changes
-------
+2.0
+~~~
+
+* Removed support for the alternate usage. The recommended usage (as a
+ distutils command) is now the only supported usage.
+* Removed support for the --junitxml parameter to the ptr command. Clients
+ should pass the same parameter (and all other py.test arguments) to py.test
+ via the --addopts parameter.
+
1.1
~~~