summaryrefslogtreecommitdiff
path: root/README
diff options
context:
space:
mode:
authorJason R. Coombs <jaraco@jaraco.com>2012-09-07 16:29:25 -0400
committerJason R. Coombs <jaraco@jaraco.com>2012-09-07 16:29:25 -0400
commitde551c6cf7e79e7f8b4c7948302d4549cc2245c2 (patch)
tree9c8d12e48a8cc6ca25a5048e1065670f06905755 /README
parent142f49d4c413f62f25f04b4bb0703c7a01bf0dfa (diff)
downloadpytest-runner-de551c6cf7e79e7f8b4c7948302d4549cc2245c2.tar.gz
Added support for --addopts to ptr command1.1b1
Diffstat (limited to 'README')
-rw-r--r--README22
1 files changed, 15 insertions, 7 deletions
diff --git a/README b/README
index 12f9046..c72e057 100644
--- a/README
+++ b/README
@@ -7,27 +7,35 @@ runner.
Recommended usage
-----------------
-- add 'pytest-runner' to your 'setup_requires'
-- include 'pytest' and any other testing requirements to 'tests_require'
-- invoke tests with setup.py ptr
+- Add 'pytest-runner' to your 'setup_requires'. Pin to '>=1.0,<2.0dev' (or
+ similar) to avoid pulling in incompatible versions.
+- Include 'pytest' and any other testing requirements to 'tests_require'.
+- Invoke tests with `setup.py ptr`.
Alternate usage
---------------
-- include this file (ptr.py) in your repo
-- add these lines to your setup.py::
+- Include the file `ptr.py` in your repo.
+- Add these lines to your setup.py::
execfile('ptr.py')
setup_params = PyTest.install(dict(...))
setuptools.setup(**setup_params)
- Where '...' are your normal keyword parameters to setup()
+ Where '...' are your normal keyword parameters to setup().
-- invoke your tests with setup.py test
+- Invoke your tests with setup.py test.
Changes
-------
+1.1
+~~~
+
+* Added support for --addopts to pass any arguments through to py.test.
+* Deprecated support for --junitxml. Use --addopts instead. --junitxml will be
+ removed in 2.0.
+
1.0
~~~